Cloudflare Gateway not blocking content

Hello Cloudflare Community,

I recently decided to switch over my policies to the new DNS tab, I thought everything was working fine until I saw that I was able to access Adult and other inappropriate content. Below are my current policies:

And here is my location page:
(Imgur: The magic of the Internet)
My question is, how do I assign policies under this new DNS system? Or does this happen automatically? Or is this a bug? I have my DNS settings set at the router level.
Thanks.

  • FiberNYC

Also, the rule ID’s are blanked out for security reasons. I would be happy to give this to Cloudflare support if needed.

From my understanding and testing the rules you specify in the new DNS tab should get automatically applied to all your locations unless you specify a more specific selector in a rule (e.g., user email or source IP address for a registered location).

Hello.
Thanks for the reply Kevin. Funny thing is, the rule was working until I woke up this morning. But the suggestion you gave me about the source IP is not working.

OK. So after some fiddling around, I found a solution. When selecting the content categories, it appears that cloudflare has that same section twice on the list. You only need to hit that selection ONCE.

This appears to be a bug within the new DNS system. A̶l̶o̶n̶g̶ ̶w̶i̶t̶h̶ ̶s̶o̶m̶e̶ ̶d̶o̶m̶a̶i̶n̶s̶ ̶s̶u̶c̶h̶ ̶a̶s̶ ̶p̶o̶r̶n̶.̶c̶o̶m̶,̶ ̶s̶l̶i̶p̶p̶i̶n̶g̶ ̶t̶h̶r̶o̶u̶g̶h̶ ̶t̶h̶e̶ ̶c̶r̶a̶c̶k̶s̶.̶

Disregard the last part, it was a caching issue. All fixed now.

2 Likes