CloudFlare Gateway and not filtering

Hello Guys,

This is a new account trying out web filtering for my family. I set up the DNS IP and on my router I also tested setting the PC with the DNS directly as well and do not see anything in the logs and nothing is getting filtered.

I even tested the following tool to check my DNS server and this is the results…

“ Cloudflare Ashburn, United States”

This was from using

What else I’m missing here? Any help is appreciated…

I have a similar setup, but always double-check from the device itself what DNS settings it’s using. On my Apple devices, the network info shows the DNS IP addresses I’ve set at the router.

You also need to make sure that the “Location” IP address at Teams Gateway is correct. For testing, you may want to add a Policy that’s active for that location. Have that policy block an easily testable domain.

Thank you that was the part I was missing. Is there a way for the location public IP to get auto-updated via script or something?

I’ve not found a way. I usually make API calls for such settings, but I don’t know if Teams Gateway uses the API. Teams Access does, so that’s a bit of a mystery. Maybe another @MVP knows if Gateway supports API calls.

Depends on your device if it supports DoH or IPv6, then a public IP isn’t required

Cloudflare Gateway will receive DNS queries from this address. The source IPv4 address is not required if you are using IPv6 or DNS over HTTPS.


On my mobile device I deleted the source IPv4 address as I can use CF Warp For Teams and login an use my DNS over HTTPS settings on my mobile device

Same with Warp for Desktop teams setting DoH to Team Gateway DoH generated server


This topic was automatically closed after 31 days. New replies are no longer allowed.