Cloudflare for domaib

Hi, today i set up a cloudflare account to direct my website to a home device. I have updated nameservers and when looking at a propagation check it shows the nameservers go to cloudflare. However, when I visit the page, it still shows as parked with Fasthosts. I have cleared the cache and tried different browsers and mobile phones but still the same. Have I missed anything?


This is what i see in cloudflare

and my nameservers at fasthosts
cloud1

What is your domain? Is there a DNS record for it that is pointing to fasthosts?

the A record on Cloudflare 213. points to fasthosts, should that be my IP? other than that the nameservers are as above for cloudflare

If I ping the website i get Cloudflare IP returned 104.21.66.186 and 188.114.97.1

Fasthosts

cloudflare

If you want Cloudflare to point at your (home?) server, then yes. Otherwise requests will go to Fasthosts.

What is the CNAME pointing to?

Cname points to my domain name, so a record should be www then my wan address not the 213.171.195.105 (fasthosts)

I want it to point to a device ( Home Assistant server) so would it be my internal IP address for that or my WAN address?

It needs to be the WAN IP address so Cloudflare can connect to it.

If the CNAME points to the same IP, then you can just change the A for www to a CNAME and point it at paulpalmer.co.uk

I followed all instructions to set up HA and cloudflare. Now this confuses me. The laptop I set this up on works just fine in that I type the url and it accesses my home HA via my WiFi, hotspot on phone or another network away from home. If however I try this on my phone, my wife’s phone, via data or WiFi, my home PC, my tab, I get this below some 48 hours later. It can’t be my isp as I can use that on my laptop, so is something like a mac address registered, I just can’t figure out why my laptop only can connect, all caches cleared, tried other browsers, at a total loss as to why

Do you have the port being forwarded on your router? It could be easier to use a tunnel to handle the connection from Cloudflare to your origin service.

This is using a tunnel

Your www isn’t using a tunnel as it is an A record to an IP address,

1 Like

It uses a tunnel with home assistant

type or paste code here
```https://youtu.be/Qsz1OjlGidU?si=Hb51vNnPX7Lg64u8
Just tried again still OK with my laptop but nothing from phone or. Home PC.

Have you changed the www record it to a CNAME and configured the tunnel with a new public hostname for it?

Folowed these instructions [[Preformatted text](https://github.com/brenner-tobias/addon-cloudflared/blob/main/cloudflared/DOCS.md#configurationyaml)

Your site loads fine for me?

The error page you were getting is for the www record.

1 Like