Cloudflare flagged my static IP adress, now streamlabs is just showing captcha codes


#1

Hey cloudflare community, I have a problem. I got a new ISP last week and they hooked me up with a static IP, everything was fine. Since I got really good upload speed, I decided to stream some games on twitch, so i downloaded streamlabs and started streaming.

Today I started streamlabs but on every widget it just tells me to go to sreamlabs.com and enter a reCAPTCHA. So I went there, clicked on the box, and I got redirected to streamlabs.com. But in streamlabs it still just shows these “one more step…” messages…I tried:

  • a maleware scan with malewarebytes
  • rebooting my router (HITRON CGNv4)
  • rebooting my PC
  • fillig in these captchas on different browsers (chrome, edge, IE)
  • deleting cookies (chrome)
  • incognito mode (chrome)
  • talking to the streamlabs support, they just told me that cloudflare probably flagged my IP
  • the privacy pass chrome extension (didn’t help, because on most sites I just get looped)
  • checked my IP on projecthoneypot.org, they had no data, I still whitelisted my IP
  • using a VPN, everything worked fine
    While trying to get to the support.streamlabs[.]com (also had the same problem with support.cloudflare[.]com) site, I had difficulties filling in the captcha code, because I just got looped (It even looped with privacy pass, which was quite weird to witness).

So I have no idea what to do…Is there a way to resolve this? Will it go away after two weeks?

Some pictures: http://prntscr.com/marjdx
Oh yeah, just realised that my screenshot tool prntscr.com also uses cloudflare and I get looped there too!

Thanks in advance,
Chris

EDIT: Also when my IP is not listed on projecthoneypot.org, am I wrong assuming my IP isn’t the problem?
What could be the problem?


#2

That will go away…as long as you don’t do something to re-trigger the block. You could ask streamlabs to whitelist your IP (I don’t know how responsive they’d be). You can also get Privacy Pass:


#3

I have the exact same issue. Anything using Cloudfare is popping up the reCAPTCHA. It’s really annoying. I was streaming with Streamlabs Chatbot and just OBS Studio.


#4

Hey, thanks for your answer!

The problem is, I don’t even know what triggered that behavior, so I’m not really sure if it will go away or how to avoid it.
I asked the streamlabs support team if they could whitelist me, but they don’t do whitelisting!
Privacy pass didn’t work for me, since finishing a captcha on some websites just makes me do a new one instantly. So when using privacy pass, it’s an infinite loop between solving and getting a new captcha.
Also I cannot access the cloudflare support website, because that captcha is looped.


#5

Hey darthdraz,

there are tutorials (written and on youtube) how to get rid of that behavior!
OBS studio should have browser source interaction, so if you rightclick the captcha there should be an option called “interact”.
Also the streamlabs chatbot recaptcha thingy is a known problem, there is a spanish/english tutorial video on youtube!

Hope I could help.


#6

Yesterday I no more captchas showed up, so I guess it really did resolve itself! I still don’t have any idea where it came from…


closed #7

This topic was automatically closed after 14 days. New replies are no longer allowed.