Cloudflare fetch a wrong page while DNS proxy enabled

Domain: shuifucarwash dot com

Question: CF always fetching error page 403 (tesing 123) from apache server while DNS proxy on.
The site working good when we turn off the DNS proxy to DNS only or pause the CF.

The site working good both on http or https

Any suggestions please?

We have tried to remove the domain and add again, failed
We have tried to add another domain in CF board, it runs good.

This is not a Cloudflare error. The Error 403 is a permission error on your centOS server which is 1to1 forwarded and proxied by Cloudflare.

This very likely is:

  1. not a Cloudflare error
  2. not a DNS/1.1.1.1 error
  3. an error at the origin

Please reconfigure your server, so that the user the webserver is running at, is able to request the necessary files.

Thank you dear,

We have tried to turn off / pause CF, then everything works fine,
When the DNS proxy on , then we got 403 from chrome

I am confused, does apache feed a wrong page ? how can i check please?

That is very strange, normally errors do not happen like this. But the error you are getting is from CentOS and not a Cloudflare branded error.

Yes, that is too strange, when the CF off everything good, we have suspected anything wrong with apache then we add another domain from CF board, it running good.

only for this domain shuifucarwash returning 403
there are more domain running on http and https all good.

This domained earlier bind to CF around 2 month ago when i saw it wrong last week it was set to ssl/tls strict, then i change it to flexible, but no luck. then i remove the domain and bind again still failed and returning 403 error. it frustrated me so much.

Can anyone help please

When it works unproxied but not proxied and then returns an error 403 (permission denied). Then likely I can not help you, the technicians from CF would have to look into it. Lets wait untill some of them come online in some hours.

Please be patient and wait for a reply. I will see later if I can find/contact any of them.

Appreciate dear Martin.
have a good day.

now https looks good

http good


domain with www, still error 304

SSL/TLS set to flexible

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.