Cloudflare errors after upgrade to php7.3

Hello guys, I have a problem with the Cloudflare after upgrade my Wordpress server from php7.2 to php7.3. Before the upgrade i used PHP Compatibility Checker and the scan passed successfully for the Cloudflare plugin. After the upgrade PHP Compatibility Checker give this results:

FILE: /var/www/html/wp-content/plugins/cloudflare/vendor/cloudflare/cloudflare-plugin-backend/src/SecurityUtil.php

FOUND 2 ERRORS AFFECTING 1 LINE

16 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
16 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
FILE: /var/www/html/wp-content/plugins/cloudflare/vendor/symfony/yaml/Inline.php
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
55 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
FILE: /var/www/html/wp-content/plugins/cloudflare/vendor/symfony/yaml/Parser.php
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
76 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2

Also covered at WP Cloudflare Plugin PHP 7.2 issue

This topic was automatically closed after 14 days. New replies are no longer allowed.