I had Cloudflare for over a year now. My domain is active on godaddy. My hosting is active on JustHost.

Everything was working fine before. I decided to disable Cloudflare and enable it in the cpanel of JustHost instead. In order to use railgun for free…

Problem is that the option railgun is not visible in the Cloudflare cpanel app…

So after having some issues with my host and trying to solve this i’ve decided to disable the Cloudflare cpanel app because of poor layout and restricted options…

I couldn’t find my Cloudflare name servers through but neither was it visible through the Cloudflare cpanel app of my hosting company.

This is why disabled it through cpanel and enable Cloudflare back through instead…

Now i received new name servers, i have pasted them in godaddy like i did before, and when i try to go on my website i get This page isn’t working ERR_TOO_MANY_REDIRECTS try clearing your cookies.

I don’t know what i’m doing wrong and why it’s suddenly not working anymore. I thought it was a propogation issue so i waited 24 hours but it’s stil not showing up…

Too many redirects are often caused by an SSL setting of Flexible (check your Cloudflare SSL/TLS settings). If your web server has SSL installed, you can try an SSL setting of Full or Full (Strict).

What’s the website address?

1 Like

Is it possible that there were some settings changed on the server? Or some Page Rules added?

1 Like

What kind of settings do you mean?

I checked my dns zone settings on my hosts server everything seems fine… I’ve contacted my host also and they told me to contact Cloudflare to solve the problem. Everything seems fine on their side. IF i would change the dns names on my domain registrar back to the original hosting dns names the website works again.

If i setup Cloudflare and put the Cloudflare dns names at my domain registrar it suddenly doesn’t work anymore. Something i have never experienced in the past, strange…

If you post the Domain URL, someone can take a look.

1 Like

Nevermind i solved it myself thanks you can delete this.