Cloudflare Email Routing not working - how long does it usually take for MX records to propagate?

I was recently accepted into the Cloudflare Email Routing beta and after setting everything up correctly (according to the dashboard), have not been able to get it to work.

This was 24 hours ago. I was previously using another e-mail service, but I removed their MX and TXT records before I added Cloudflare’s.

At what point should I begin technically addressing the issue?

1 Like

Thanks for the report.

Have you tried to turn off and on again the catch-all on the dashoard? That will force our API to publish the configuration, it should take up to 60sec to propagate.

It’s a known bug and we are working to resolve that soon

Hi, I’ve tried the turning the catch-all on and off again and it still doesn’t seem to be working - even after waiting 48 hours.

Any other recommended troubleshooting steps? I’m successfully using Cloudflare for DNS resolving for my sites and all of the options on the Email Routing dashboard are configured successfully (according to Cloudflare).

@halpdesk could you please share the domain you’re using?

Sure - my domain is “shol.ly”.

Seems to be working.
If you sent a test email from a gmail account and forwarded with Cloudflare back to the same Gmail account, gmail will deduplicate the email and hide it in your inbox. Could you try using a different gmail account or an online service?

1 Like

That seems to have been the issue! I’m so sorry I hadn’t thought of trying that before. Thanks!

no worries, it’s not obvious at all. We’ll make it more visible in the future

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.