Cloudflare Email Routing ends with 550 5.1.1 Domain does not exist

Hi!

I’ve got access to the Cloudflare Email Routing on few domains - when I wanted to configure it on one of them I skipped the tutorial/first steps because wanted to use just a single wildcard/catch-all. Probably because of that the domain was not activated on your end and all e-mails attempts ends with 550 Domain does not exist. Domain is configured in Cloudflare panel, DNS entries are there (manual copy-paste rather than automatic creation - because there is no link for that if you skip tutorial/first steps), e-mail addresses validated, catch-all and normal single forward alias created - it still ends with 550 Domain does not exist on everything related to this domain. This really seems like it isn’t enabled on your end, however according to limited data I have in panel it “should work”.
Attempts to fix it - I’ve tried:

  • deleting other DNS record
  • enabling Under attack mode
  • enabling Development mode
  • enabling Email Routing (with tutorial, this one works!) on different domain hoping reload is ‘account wide’, not only domain wide.
  • adding more destination addresses in Email Routing section
  • toggling on/off (multiple times with waiting like 2 minutes between) Catch-all address/Custom addresses
  • toggling off other random settings in CF - like “Scrape shield” or “0-RTT Connection Resumption” hoping it will somehow force reload

I fully understand this is Beta service, but seems like I managed to break it and there should be some direct CF support contact for beta services.

Yes, DNS settings are totally correct even from outside CF network - it all connects to 220 mx.cloudflare.net ESMTP ready and after providing e-mail recipient it throws 550 Domain does not exist. This was all done 10+ hours ago.

This is little obfuscated/censored copy of ticket #2339927

Have you tried to turn the catch-all off and on again? I’m suspecting you are running into a known issue of our API/dash.

Yes, I did it multiple times like mentioned in first post.

However this time it worked, thanks for fixing.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.