Cloudflare don't pass requested url, plz advise!

cdn
firewall

#1

I have a small office setup

  • 3 web servers all have certs assigned to them.
  • pfsense + HAproxy configured to listen on port 443
  • HAproxy have conditional rule to route the traffic to the corresponding server based on the host name in the requested URL as follow:
  • https: QC.domain.c.o.m > Srv01
  • https: Web.domain.c.o.m > Srv02
  • https: doc.domain.c.o.m > Srv03

The setup works great if HTTP proxy(CDN) is turned off for DNS records on Cloudflare, but once i turn them on i get Error 522 “Connection timed out”

it seems that cloudflare dont pass the actual requested url back to the firewall when CDN is enabled, or i could be missing a setting !!

please advice


#2

What’s your SSL setting here?
Are there any firewall rules in place on, or in front If your haproxy? Make sure this IPs are allowed:

That’s a snippet of my haproxy config. Very basic…


#3

Try this solution and please update if it works


closed #4

This topic was automatically closed after 31 days. New replies are no longer allowed.