Cloudflare doesn't work after hosting IP update

I’ve been using Cloudflare for about 4 years, without any issues. About a month ago, my hosting provider decided to move my site to ‘Optimized wordpress’ plan. This means - my IP was changed to a new one.

It also means I had to change options in Cloudflare, since it was still pointing to my old IP.

I wasn’t very technical, so asked my hosting’s support to help me adjust Cloudflare… I spent the next 2 days trying to do it - every time I switched Cloudflare on with new IP - it wouldn’t work.

I did step-by-step everything these hosting tech guys told me to, and Cloudflare still wouldn’t work properly. I had to switch everything to ‘DNS only’ status in Cloudflare… but I can really see the site working times slower than before.

I understand I might have changed records in Cloudflare I shouldn’t have, but i dont know what to do. When I spoke to my hosting, they said ‘not our problem, contact Cloudflare’… i kept explaining that before this IP change everything was working fine with Cloudflare, and now it doesn’t.

anyway…

In the screenshot - RED are the spots where I changed the old IP address to new one (as my hosting told me to do). Cloudflare doesn’t work with the new IP once turned on… so I had to switch off everything to ‘DNS only’.

  • My hosting says its Cloudflare’s fault. I am not skilled enough to keep playing with the records.

How can I adjust the records? Should I delete the site from Cloudflare and re-add it? Any other advice?

I’d appreciate some advice. Thank you.

What error are you getting exactly? After enabling Cloudflare

One of the mistakes I was getting was “the page isn’t redirecting properly”. The hosting guys told me there were some issues with SSL, they did something, but eventually, with Cloudflare turned on, the site wasn’t working.

I suspect I just made some wrong changes to the records, as advised by my hosting…so nothing works now.

What’s your current SSL level?

Currently, it says “Flexible”.

My host said this: “The page isn’t redirecting properly”.is usually caused when the SSL mode selected at Cloudflare tries to make an HTTP connection between the origin server. When the origin server tries to redirect to HTTPS (due to the Home and Site URL, forces the redirection code, HTTPS redirect plugins) this causes the error. Please do access the Cloudflare dashboard and have the SSL settings/Encryption mode set to Full (strict) mode and have the Cloudflare CDN enabled to check if this resolves the issue. "

I haven’t tried it yet, afraid to mess everything up even further.

Any suggestions?

If you switch to flex mode and your website works that mean it is website SSL is working properly. Make sure to pause the website on Cloudflare and see if the website is working on https and SSL is working. After that turn on Cloudflare with strict SSL and that should make things work

If you switch to flex mode and your website works that mean it is website SSL is working properly. Make sure to pause the website on Cloudflare and see if the website is working on https and SSL is working. After that turn on Cloudflare with strict SSL and that should make things work.

Currently, its on flex mode. Cloudflare is ON, but only ‘DNS only’ on all records. If I switch A-record to “PROXIED” - the site stops working.

If I pause Cloudflare completely, then the site works, but slowly.

So basically, right now its like this:

  1. Site works with Cloudflare on (flexible), but with all records on ‘DNS ONLY’.

  2. Site doesn’t work with Cloudflare on (flexible) with records PROXIED.

  1. should be proxied dns records :norange: and SSL mode as full strict and assuming SSL works at hosting provider. That should make your website up

Got it. What records I need to set to proxies? Only the A-record (main site) and its subdomain? Please look at my screenshot in this topic and advice me which ones to set to PROXIED.

I’ll switch to strict afterwards… my SSL at hosting seems to be working.

If you switch to proxy mode it won’t work unless you switch to strict SSL

The A and cname should be proxied with Full strict SSL mode

So assuming SSL at server works fine, i take these steps:

1 - switch to Strict mode first.
2- then switch on PROXIED (A-records, cname)
3 - purge cache just in case

Looks good?

Awesome!!

It lives! It lives!!! Thank you, friend! )

Happy for you :joy:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.