Cloudflare doesn't purge its cache

Yesterday I was trying to change one option of the WP Autoptimize plugin (inline and defer css) to avoid it render blocking. This was the process of it:

  1. I extracted the critical css with an online tool and added it to the plugin.
  2. Activated the option and then saved and emptied both Autoptimize (AO) cache and WP Super Cache (another complementary cache plugin)
  3. Activated development mode and purged everything in Cloudflare panel.
  4. All worked perfectly so I left the new AO option on.
  5. A day later my site has stopped working, returning a Cloudflare 504 timeout frontend and backend.
  6. Activating dev. mode and purging cache doesn’t work. The site only gets back to normal if I pause Cloudflare on the site.
  7. After that, I deactivated “inline and defer option” in AO but Cloudflare cache is still broken.
  8. Since there’s no way to purge the cache or fix it activating dev mode I can’t activate Cloudflare again without breaking my site. I must leave it paused.

Any help on how to purge the cache would be appreciated.
Also if anyone knows how could the option “inline and defer css” break my entire site. I have activated other times before having Cloudflare and the website loaded. With Cloudflare it should load no problem as well only showing messed up CSS but not timeout Cloudflare. I’m completely flabbergasted.

Thanks for your attention.

Without seeing it in action, it’s hard to tell. Those may be unrelated, or maybe it just takes a very long time for the server to respond with those settings.

Thanks @sdayman is there a way I can give you access to my CPanel and website via PM so you can see it in action?

I’ve read the article and it can’t be Namecheap server returning a 504 to CF since it works perfectly as soon as I pause CF. Before changing Autoptimize setting it worked fine so now that AO is as before it should work well again.

Neither is overloaded, it has very low traffic and the stats in CPanel show is not overloaded.

The third cause and the rest cannot be as well. As soon as I activate CF it returns a 504 error page from Cloudflare specifically.

I managed to isolate the error to this problem. It seems that my Cloudflare doesn’t purge the cache when I ask it and website changes take a day or so to update in Cloudflare’s cache.

Best case scenario Cloudflare cache will update tomorrow and I will be able to activate it. Worst case, since CF is paused on my site, the cache will stay frozen in a broken state and I could not be able to reactivate it.

Also I tried solving the issue with Namecheap support and all is well on their part. The problem is with Cloudflare.

Again can I pass you my website and CF username in case you want to see it for yourself?

This topic was automatically closed after 31 days. New replies are no longer allowed.