Cloudflare does not working

Hello! Recently I learned about cloudflare, and wanted to give it a try, so I selceted the free plan. Added an A record pointing to my server’s ip adress, and added the record. Selected full portection, and turned on attack mode. Then I waited 4-5 hours. Now if I type my domain it says webserver is down, and if I type my server’s ip adress it gives me the page. Can someone help me please?

Without the domain? Not really :wink:

And while we are at it, throw in the IP address as well.

And, did you use the search too?

I did both, I added an A record for the domain hahota.fun, and pointed it to my server’s ipv4 adress.


Sorry, what do you mean?

If you used https://community.cloudflare.com/search?

How is that relevant?

It seems as if you didn’t not use the search, which would have been a good idea as you’d have come across Community Tip - Fixing Error 521: Web server is down

Anyhow, as the error is pretty clear about, your server is not reachable. Assuming your server IP address ends in 161, it simply would appear your server is not configured for HTTPS. Make sure it is and that it has a valid certicate and you should be good to go.

This migth sound dumb, but what do I need to do to make it work. Doesn’t cloudflare gives me an ssl certificate for https?

It does not. Cloudflare only issues certificates for their proxies. You still need to configure your server properly.

As I said

If I set the option off, I will need an ssl certificate still? I don’t want to buy one, I’ll might just stick to http

With “Off” you won’t need one. But keep in mind Lets Encrypt offers free certificates and even Cloudflare offers free certificates via “Origin certificates”. All in all it takes a couple of minutes to have a valid certificate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.