Cloudflare does not load the image (logo) in the e-mails signature


#1

Hello,
I need a help.
I don’t know is this right place, but i have problem about loading picture(logo).
I use Cloudflare free plans.
In signature of my emails is logo and it is broken.
All pictures is in same subdomain “media” on the same server where is the website.
Everything else work fine except logo. That link doesn’t work properly.
When I return my hosting DNS names it is working ok.
I followed instructions for similar problems (https://support.cloudflare.com/hc/en-us/articles/200169906-Why-are-images-or-pictures-missing-on-my-site-) and advice about turning off Rocket Loader in Speed section, but result is same.
I don’t know what to do.
If you have some idea i will be appreciative.

Thank in advance,
Dule.


#2

I suspect it’s due to Hotlink Protection preventing direct linking to website images. You can turn this off in the Cloudflare Scrape Shield tab.


#3

Тhanks for the quick reply, I will try this as soon as possible.
I hope this is a solution to the problem.


#4

Hello again,

I tried your advice, but something strange happens, but I do not understand.
When I moved back to the Cloudflare, everything worked well for about 20-30 minutes, and then the same problem. Now I tested a little more my email and I noticed:

  • when I am creating an e-mail, the logo in the signature is not visible again (broken)
  • I can send messages to everyone (I tested 4 different e-mails)
    and on @ yahoo.com and @ gmail.com logo can be seen, others can not.
  • I can receive and send messages from all who are on the same mail server (mailcluster.loopia.se).
    If you have any other idea, it would mean a lot to me.

Thanks in advance,
Dule.


#5

Is this all through webmail? I suggested hotlink protection (off) because if someone’s using webmail at yahoo.com, or gmail.com, hotlink protection will block the image because they’re trying to load the image from a web page at gmail or yahoo.

Another option would be to host the image file in http(s)://example.com/hotlink-ok/image.jpg and see if that works.


#6

Yes, it’s all happening through the webmail.
I turned off Hotlink Protection, as you said.
I can see the logo when I send an email from my domain to my @yahoo or @gmail mail, but I can not do it on the others(like ovh.net or others).
How I see logo on @yahoo and @gmail?
Why other email servers(most of thеm) can not see this logo?
And have that problem about receiving e-mails, which additionally confuses me, as well as the fact that everything works well for the first 20-30 minutes (maybe not completely configured Cloudflare settings for this time), and then it does not work properly.
The second option you talking about is not a solution because I have over 70 e-mails and can not ask everyone to insert a new link in HTML.
Thanks anyway.


#7

My last suggestion is to clear the Cloudflare cache.

If a user right-clicks on the broken image, can they load it? I hope someone can track down the error they’re getting for why the image isn’t loading.

A compromise would be to create a page rule that redirects that URL to an image in hotlink-ok. That way your users won’t have to change the link. It’s not a good solution, but it might work while you troubleshoot.


#8

I’ll try to clear Cloudflare cache.
No, they can’t load, in that case link doesn’t work.
I switching DNS usually after midnight, no big traffic in that time(Europe timezone).
Due to e-mail reception problems, is the solution in the email setup?
Before I last time returned my DNS hosting names, I noticed in the cloudflare DNS section of this setting https://www.dropbox.com/s/73d3b0qzg6g7crg/cloudflare_dns.PNG?dl=0, so I doubt this warning at the top of the page about MS records.
I’d like to ask you to just look at this.
Thank you very much in any case.


#9

The warning about no MX records is bad if that is the domain with your email addresses. Can people outside your domain send you email?

Instead of switching DNS, you can :grey: the location of your website to see if that fixes the signature image problem.


#10

Unfortunately, I think it’s the same server (ip) for email and website.
I can not receive emails from others (except from the same email server), just to send.
I’ve been watching some of your topics about this problem. I’ll probably have to try another solution.
I’ve never put only a website on a cloud location, to try your suggestion. Does Cloudflare have this option, and is it paid?


#11

Sorry, the :grey: option is in Cloudflare DNS to bypass Cloudflare. :orange: means it’s active.

If “mail” “mail2” and “smtp” are the names your MX records use for receiving mail, you need to set them to :grey:, as Cloudflare doesn’t proxy Port 25 SMTP. Same goes for imap and pop3.

Then add MX records that point to the above names that the mail server uses for receiving mail.


#12

Hello,

I didn’t write for a few days, I solved most of the problems, but not completely.
The mail server is separate, so I got the corresponding MX records from the provider and I added some records for the media subdomain, so everything worked, and the logo in the email that hadn’t been seen before. I thought it everything worked well because I tested with @yahoo and @ gmail as well as another email and it worked well. However, users told me 2 days ago that they could not receive mail from one domain that recieved return message:
Delivery has failed to these recipients or groups:
[email protected]
Your message wasn’t delivered due to a permission or security issue. It may have been rejected by a moderator, the address may only accept email from certain senders, or another restriction may be preventing delivery.

I had to return old DNS servers.

I think there are probably more domains that might potentially make the problem.
Do you have any advice?

Thank you very much in advance,
Dule.


#13

I don’t remember your domain name (your Dropbox image is gone). I haven’t seen that email message, but mxtoolbox.com is good for troubleshooting mail server configurations.


#14

These are DNS domain settings for my domain. https://www.dropbox.com/s/4wvyqwgobahnu1t/cloudflare_DNS.PNG?dl=0
I do not understand why some of e-mails from other domains are denied.
Most of domains works perfectly. Why is it selective?
Are there any options to fix it on Cloudflare?


#15

Your domain isn’t set to use Cloudflare’s name servers, so it’s difficult to track behavior.

What I do see is your current MX records do not match the MX records in your Cloudflare DNS. As I stated above, some of your mail-related DNS entries should be set to :grey:, then make sure your MX records here match the MX records you use at Loopia. Loopia might be expecting your MX records to match your domain.

p.s. I realize this isn’t the most helpful response, but the selective behavior is confusing.


#16

When I add loopia records for this domain, I getting a warning as it appears in the picture, red rectangles.
https://www.dropbox.com/s/t9kk75zprkrnx9d/cloudflare_DNS_2.PNG?dl=0 Blue rectangles are general MX records for Loopia mail server, and it worked for me.
I don’t know can I leave these records with warnings.
I’ve set all the records loopia assigned for this domain.
Honestly, I don’t know what to turn off.
If you have a suggestion, I will be happy to try. Well, if it doesn’t work, I’ll set up DNS cloudflare again, if it helps you tracking the behavior and you eventually see the problem.


#17

Do you still have mail2 and mailcluster set to :orange:? They should be :grey:, since Cloudflare doesn’t proxy mail servers.

Is there some warning above your DNS table that indicates the warnings?


#18

I’m sorry I did not give you the whole picture, here it is.
https://www.dropbox.com/s/twsoaoqcmjjbtom/cloudflare_DNS_warnings.PNG?dl=0 At the top of the picture is a warning.
I can only remove this MX record for mailcluster because I don’t have any other option.
If you have a suggestion which subdomain (Name) to remove or turn off from this DNS panel, and then we can see if it will work.
Thank you in any case for your efforts on this problem.


#19

That warning is because the CNAME points to an Orange cloud, and CNAMEs get “flattened” to return the origin IP address (I think this is unique to MX records pointing to :orange:). If it was :grey:, you wouldn’t get that warning, as you want that IP address exposed.

So…anything that starts with: mail, pop, imap, smtp need to be :grey:. EXCEPT for mailadmin.

FTP should also be :grey:, since :orange: doesn’t proxy FTP or SSH. I’m not sure if autoconfig would be an issue. Just remember that :orange: can only handle HTTP and HTTPS.


#20

Thanks for the advice.
Now there’s no warning, I hope it will work.
If you can just look at this picture, would there be something else to change? https://www.dropbox.com/s/jb24nwkhay6rlse/cloudflare_DNS_off.PNG?dl=0
I will try to replace the DNS name as soon as I can, probably late tonight (by European time).
In any case, thank you very much.