Cloudflare DNS unaware of a host?


#21

We had two lookups so far, one to the default resolver (which forwards to Cloudflare and OpenDNS) and one to Cloudflare. Both worked, the former had one timeout but we dont know the reason.

We have by far not enough data to make any educated statement and your assumption regarding the router is pure speculation based on apparent bias.


#22

The second nslookup:

C:\Users\Gerry>nslookup chicago2.voip.ms 208.67.222.222
Server: resolver1.opendns.com
Address: 208.67.222.222

Non-authoritative answer:
Name: chicago2.voip.ms
Address: 208.100.39.53

The router in question is a TP-LINK TL-R470T+, not a typical home router, but also not a SonicWall.

Another data point: I configured the DNS entries on my computer to 1.1.1.1 and 208.100.39.53, and had no problems with Zoiper. Thus, shimi may be correct, the issue could possibly be with the router.


#23

Some call it bias, some call it “seen hundreds of customers and types of networking equipment over 20 years”.


#24

We dont really have enough data to say so. From what I understood, you generally could not connect via the hostname. Is that correct? The first lookup, via your router, did time out once but eventually completed. That could point towards the router but does not have to. A handful of connection attempts is not sufficient to say if it was an intermittent issue or if there is an actual problem somewhere.

Yes, I call it bias. You want to point fingers without conclusive data. Up until recently we did not even know the brand. But I dont think that discussion is leading anywhere either, just like the OS one, lets stop please.


#25

I don’t care for the brand (though he managed to write that it’s a TP-Link before I had the time to guess that he’s most likely using TP-Link - because that’s where I’ve seen this issue the most). I have seen this specific issue in a wide variety of different routers under various conditions. Tens of times, at least. Letting the OS resolve not through the DNS proxy solved the issue. Every. Single. Time. Rebooting the router sometimes also helped, “until next time”.

The definition of a biased opinion requires the opinion to be “unfair”. If the same thing happens again and again, it is proven, not biased.

I don’t want to point fingers, I’m here to help people solve their issues. With the data we have so far, it appears that I just did. On to the next issue…


#26

Then dont do it.

I am admittedly relatively tired of bashing remarks whose purpose seems to be to lash out on certain products or companies. And with neither your router nor your operating system remark have you left a very unbiased impression I am afraid.

No, I’d argue we do not have enough data. Did not earlier and still do not at this point. Should it really turn out to be the router I’d call it a lucky shot. These routers might not be enterprise-grade (they are not supposed to be) but I have seen and also used myself quite a few of such consumer-routers and never experienced anything like what you described, particularly not in a consistent manner as described here.
If we can determine an issue with the router, fair enough, blame the router. But we were never at a point where we could do this without resorting to guessing.