CloudFlare DNS serving blank pages

Hi all, I wanted to serve my S3 bucket via a custom domain so i used this tutorial (Configuring an Amazon Web Services static site to use Cloudflare – Cloudflare Help Center). Funnily enough, it actually worked (showed working html/css) for a total of 2 hours in the morning before it started showing me a blank page (with no errors on chrome dev console).

These are the URLs:

  1. custom domain (alliedagencies.sg)
  2. S3 bucket (you can check these out to see that it is serving from the s3bucket correctly)
  1. worked in the morning with traffic screenshot (its now 1pm in Singapore time and theres no traffic, I believe cloudflare stopped serving the website)

My guess is that it has something to do with the http/https redirection, however, i cant debug this as i’m getting a blank page now with no errors, any ideas?


blank page with no errors, currently using Development on CloudFlare so caching wont be an issue

For starters, your Amazon servers do not respond on HTTPS.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.