Cloudflare DNS pointing to incorrect website


#1

Hi there,

With Google soon to rank non HTTPS websites low, I decided to use Coudflare on recommendation.

I created an account, and changed the nameservers for my domain as instructed by Cloudflare, but when I do a Google search for our page, when I click the link it directs me to a completely different webpage, so it’s not resolving correctly.

How can I make sure Cloudflare points to the correct page?

Thanks.


#2

Cloudflare uses the domain name and IP address you enter in Cloudflare DNS. It’s up to the server at that IP address to properly respond to the request.

To test this out, go to your Cloudflare DNS page and switch your website’s DNS entries to :grey: so requests go direct to that server.

If you’d like more help and are comfortable with posting the URL, go ahead an post it. If the :grey: test returns the proper web page, but :orange: does not, open a Support Ticket here or email: support AT cloudflare DOT com


#3

Thanks sdayman,

I’ve changed the cloud from orange to grey but it’s still the same

Our domain is perio-one.com.au and it’s pointing to absoluteclearwindows.com.au


#4

Your Cloudflare name servers have a typo at your registrar. You ended them with .co and they should be .com


#5

Genius, thanks. I used the built-in copy text button, but clearly it didn’t copy all. I’ve altered it now so we’ll see what happens!

Thx.


#6

Still no joy


#7

Your nameservers are pointing to syrahost.com now.


#8

Now I’m super confused.
At the account management area of the website host, my nameservers are:
anna.ns.cloudflare.com and kai.ns.cloudflare.com


#9

Name servers look good to me, but the site is redirecting to the window place.

In your Cloudflare DNS, try to :grey: setting again and see where it goes.

I’m getting a definite 301 Redirect from perio-one to absoluteclearwindows. Now it’s a matter of figuring out where that is happening. Double-check that the IP address you set at Cloudflare is the same one that your web host lists.


#10

Thanks again sdayman.

I deleted the website from Cloudflare and started again but it’s still the same. I’ve been on the phone with my host and the IP address set in Cloudflare is correct.

I haven’t heard back from Cloudflare yet unfortunately.


#11

Did you try setting it to :grey:?

Just to be clear, DNS is not pointing to the incorrect website. Visitors are connecting to perio-one.com.au, then immediately redirected to the window place.

Please set your DNS record here to :grey: and see if it works properly.


#12

All clouds are now grey and it’s still redirecting to absoluteclearwindows.


#13

Got it!

Don’t use Full SSL. Set it to Flexible.


#14

Ok, so it’s had a little more time and now it’s pointing to the correct address, but there’s an error about the SSL being setup incorrectly.

[edit] just saw your post. Will do!


#15

Your hosting setup doesn’t have an SSL certificate for your domain. Web hosts do funny things when you try to connect using SSL when your site doesn’t have SSL. Cloudflare’s “Full” SSL uses HTTPS to connect to your web server.

Anyhow…use Flexible SSL in your Cloudflare Crypto settings. that should fix it.


#16

Have changed the settings and will see if that fixes things. Thanks for the help sdayman.

The reason I went down the Cloudflare route was simply because Google will be penalising non-https websites in their search results and I want to remain higher in their listings obviously.


#17

And don’t forget to set your DNS back to :orange:


#18

Flexible SSL will give your site HTTPS access. The visitor connection looks just like any other HTTPS connection, matching the Full or Full (Strict) experience. It would be nice if you could get SSL for your server to complete the secure connection. Some other day, maybe.


#19

Thanks once more sdayman, you’ve been magnificent.

The next step is to get a SSL certificate from my host. Just so I don’t make any more rookie errors, if I purchase a certificate from the host and click full or full(strict), I should be good to go?


#20

In a perfect world, they’ll let you get a free cert from Let’s Encrypt. But which ever certificate you install, you’ll be able to use Full (Strict) to complete the circuit.