Cloudflare DNS pending verification for weeks

It appears my DNS despite being properly routed to the records I’ve set in my cloudflare account, are not being proxied by Cloudflare as it is “Cloudflare protection for your domain is in a pending state while we verify ownership. This could take up to 24 hours to complete. Learn more about [pending domains].”

When I run $ dig ns chargeblast.com I see the DNS are set to Cloudflare, however on the Cloudflare dashboard it appears nothing is actually proxied. What do I have to do?

You have added the Cloudflare nameservers to the other ones. You should delete those and only have the two Cloudflare nameservers set.

https://cf.sjr.org.uk/tools/check?ee0da74e3d3b4cdfb50ac2a0d8e217f1

can you expand on this. not sure what you mean exactly.


This is what the DNS looks like

Check with your registrar, as they show an additional 2 nameservers.

   Domain Name: CHARGEBLAST.COM
   Registry Domain ID: 2237422322_DOMAIN_COM-VRSN
   Registrar WHOIS Server: whois.namebright.com
   Registrar URL: http://www.NameBright.com
   Updated Date: 2023-12-10T07:34:23Z
   Creation Date: 2018-03-10T10:49:34Z
   Registry Expiry Date: 2025-03-10T10:49:34Z
   Registrar: TurnCommerce, Inc. DBA NameBright.com
   Registrar IANA ID: 1441
   Registrar Abuse Contact Email: [email protected]
   Registrar Abuse Contact Phone: 17204960020
   Domain Status: clientTransferProhibited https://icann.org/epp#clientTransferProhibited
   Name Server: BETTY.NS.CLOUDFLARE.COM
   Name Server: MARVIN.NS.CLOUDFLARE.COM
   Name Server: NS1.NAMEBRIGHTDNS.COM
   Name Server: NS2.NAMEBRIGHTDNS.COM
   DNSSEC: unsigned
   URL of the ICANN Whois Inaccuracy Complaint Form: https://www.icann.org/wicf/

Is it common for a name registrar to append their own 2 extra NS? I don’t see any way to edit this in the domain registrar

You will need to contact Namebright. If you deleted the Namebright nameservers, they shouldn’t be there.

https://community.letsencrypt.org/t/guide-to-change-dns-servers-from-namebright-to-cloudflare/41687

I followed this to a tee. You think it would be a bug? I’ve been waiting for a week+. Seems like no one would be able to use cloudflare with namebright if this was platform wide. should i try removing them and then adding them again?

This domain was updated in the last 3 days. If this was to update the nameservers or configure DNSSEC then your change may not have fully propagated across the internet yet. You can check [here](https://dnschecker.org/#NS/chargeblast.com) .

I just updated it again. Perhaps it would take 3 days for them to remove their NS?

You can try setting back to default nameservers (you may need to wait a bit), then setting them back to Cloudflare again.

Is it possible that Cloudflare is actually appending the 2 Nameservers somewhere?

No, the WHOIS lookup only looks at your registrar.

I spent 10K on this domain… and theyre not letting me migrate it off this garbage registrar. You think if I complained to the company I bought it from saying I can’t use it unless they move it to a different registrar they’d accommodate?

figured it out. just needed to try it again i guess. very weird

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.