Cloudflare DNS on Mobile can’t make changes

dns

#1

Not sure actually if this is so much a DNS problem as it it something to do with making the changes using a mobile device, but it’s been this way now for the last month or so.

Basically when you try to make any changes via mobile, like grey clouding a DNS record, anything within the DNS tab, it always throws the same error code about the TTL, see attached pic.

If I do this with a computer, obviously there’s no problem and it doesn’t give the same error code. Currently tho my MacBook is broken so I’m having to delete the records, and add new ones with the change already made.


DNS Validation Error (Code: 1004): priority must be an int between 0 and 65535. (Code: 9104)
9104&9021 Error
DNS Validation Error
DNS Validation Error (Code: 1004): Invalid TTL. Must be between 120 and 2,147,483,647 seconds, or 1 for automatic (Code: 9021)
#2

It only seems to affect CNAMEs. At least A records can be edited under the mobile view as well.

The underlying problem appears to be the mobile view sends the JSON value for the TTL not as number (as required) but as string ("1" vs 1) and that is not appreciated by its counterpart on Cloudflare’s side :wink:

@cloonan @cscharff


#3

The issue is basically replicated for me on almost any other DNS setting on mobile that has TTL settings. Not if you create a new record, but if you’re editing an existing DNS record. I’m using Cirrus now so it’s not a big deal but like, probably soemthing Cloudflare should fix lol.


#4

I have only tested A, which worked. I would expect it to work for you too.

As for a fix, that should be relatively easy to do.


#5

A works for me ! Haha


#6

Until that value is switched to a number, you can simply request the desktop page.


#7

Any request desktop version made on Cloudflare just return the exact same mobile page. At least on iOS.


#8

Maybe try to switch to the desktop version before you open the DNS settings or maybe even before you log in. Just a guess though, didnt test that on a mobile device.


#9

Same happened to me. I deleted the CNAME entry and created a new identical one and it worked!

Is that what you’re doing too?

Also, why not turn them all on? Do you only need certain ones turned on?

I saw a video suggest only two or three need be turned on. But I didn’t know why


#10

The OP mentioned he can create records.


#11

Yeah like creating a new record after deleting the original one is not a problem at all, it’s jusy making changes to that existing record and then trying to save those.


#12

Seems the issue is not fixed yet.


#13

yes.Other types can solve the problem by recreating the record, but the mx record does not. A 9104 error occurs when it is created.


The only perfect way I can think of is to export the DNS file and edit it. Then I upload the DNS file again. Although the problem can be solved, it is very troublesome.


#14

To also add to this, another error is produced on mobile when donating to request early access to Cloudflare Registar. This isn’t an issue as obviously, donations to any charity are awesome, just emphasizing somethings going on with Cloudflare on mobile.


#16

#17

Sorry for not getting a response on this sooner, but there are some known issues with adding/editing DNS records on mobile and the team is working to address them. We expect to have this cleared up soon, but in the meantime have to ask that users who encounter integer validation errors on mobile DNS switch to a desktop.

Sorry for the inconvenience, but I assure you that it’s being worked on.