Cloudflare DNS not resolving to my domain

Hi there,
I create a new domain on GoDaddy and changed the DNS to Cloudflare on the domain settings page. It took 24hrs, but they now show cloudflare dns.

However when I try to reach my domain manishjain.cloud, it says site not found or 404 error.
I have even tried adding an A record on cloudflare pointing to a test site I created on godaddysites.com but that too is unreachable.

Not sure what I am missing? I thought I should have to only change the DNS settings on my GoDaddy for this to work.

thanks in advance,
Manish

Was your domain up and running before you added it to Cloudflare?

You may have to go to the Overview section of the Cloudflare dashboard and click Pause Cloudflare on Site the wait five minutes for it to take effect. Then see why your site isn’t loading.

Hi sdayman,
Thanks for your response. I paused it but its still not reachable. Domain was reachable when I first created it on GoDaddy, but once I chance the DNS to cloudflare, it stopped working.

I also noticed in cloudflare overview, that its say the registrar is not recognized. Not sure why not as it found it when I first tried to search the domain on cloudflare.

image

image

On GoDaddy Domains page, DNS reflects cloudflare DNS:
image

You don’t need to worry about the Registration stuff, as everything else here is properly configured, including the name servers.

Now that you have Cloudflare paused, connections go directly to your server. And it’s still showing a 404. So it’s definitely a server issue.

Double check your DNS records here and make sure they match the DNS records at GoDaddy…especially the IP address.

DNS server names match. How do I check the IP addresses?

The DNS tab here has a list of your records. There should be something similar at GoDaddy.

Both GoDaddy and Cloudflare both have the same DNS servers names. Here is the Cloudflare.

What else I can do to resolve this?

You need to Add Records so you have all the “A” and “CNAME”, etc. records as in your GoDaddy account.

Its not clear to me what to put in the A or CNAME. I tried adding https://manishscloudsite.godaddysites.com/ which is a test website page I created as CNAME and it did not work.

Appreciate your help in troubleshooting.

Sorry, only GoDaddy would know what your DNS records should look like. Hopefully their support people can point you in the right direction.

A @ Parked 600 seconds
CNAME www @ 1 Hour
CNAME _domainconnect _domainconnect.gd.domaincontrol.com1 Hour

GoDaddy removes all A/CNAME entries once I change the name servers to cloudflare. The above entries are when the name servers were still pointing to GoDaddy. Cloudflare did not allow me to add the A details as per above.

What should I add to cloudflare?

Any suggestions?

I added CNAME to cloudflare, still can’t reach my site yet:
CNAME _domainconnect _domainconnect.gd.domaincontrol.com 1 Hour

At this point, it’s best to start over. Set your name servers back to the GoDaddy ones and get your site up and running properly with HTTPS. Then take a screenshot of your DNS records at GoDaddy so you can add them here.

Here are the GoDaddy DNS settings, which ones should I add. For example, Cloudflare does not allow me to add the A -> does not accept “Parked” as the value.

Type Name Value TTL Actions
A @ Parked 600 seconds
CNAME www @ 1 Hour
CNAME _domainconnect _domainconnect.gd.domaincontrol.com1 Hour
NS @ ns47.domaincontrol.com 1 Hour
NS @ ns48.domaincontrol.com 1 Hour
SOA @ Primary nameserver: ns47.domaincontrol.com. 1 Hour

Cloudflare can’t fix this. You’ll have to work with GoDaddy to get your site working again on GoDaddy.

I was asking, which ones of the GoDaddy DNS records shall I add on Cloudflare?

thanks

This topic was automatically closed after 31 days. New replies are no longer allowed.