Cloudflare DNS leaktest show very remote location with firewall nslookup ends with “ can’t find nslookup non existent domain

Hi I have been unable to figure out how to configure my firewall to correctly resolve cloudflare Dns. I am using Firewalla gold router mode and have tried everything from using the resolver cache, To entering manual IP for DNS on the end device. When I run something like DNS leaktest I get a list of servers either in Germany or in UK for cloudflare and I am in Tel Aviv, where there is a Data center of cloudflare Within sight. When I try to use wrap Over my cell phone connection, I get the Tel Aviv data center in pinging speeds of less than 10 ms but if I’m even successful with Firewalla it can be 100 or more. I’ve Tried with or without DNS over HTTPS enabled But it always keeps happening. I would greatly appreciate any help. By the way when I was blocking just to test it was blocking Australia, and what it’s trying to help me sign up for a free plan which I don’t understand and that requires a credit card for zero dollars, it’s defaulting to Germany as well but registering my correct IP which is a dynamic one so registering it would not help however it would remain in the same location and I do have a DNS any help would be greatly appreciated I’m not sure what I need to do as a consumer

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.