Cloudflare DNS is not working

I created an A record a week ago. Everything was working fine but now I’m unable to view my page externally. The record is correct when I look at my Cloudflare account but when I check from whatismyip dot com it returns an incorrect IP address. I bought my domain through Cloudflare but doesn’t seem to have any support.

The IP is likely different because the record is proxied so my assumption is that the proxy functionality isn’t working.

Welcome to the Cloudflare Community. :logodrop:

Are you sure that it isn’t returning one of the many Cloudflare proxy IPs? That is normal behavior when the record is :orange: and is required to deliver the security and performance features of the service.

Have you tried setting the name to :grey: DNS Only to make sure that your site works correctly over HTTPS with a direct connection?

I’ll try that now. How long does it take to update?

It actually worked pretty quickly. Yes the site works now externally.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.