Cloudflare DNS IP Change Doesn't Work and Just Redirects


I am using Namecheap Domain and Hosting.

I have bought the Namecheap VPS Quasar. I have moved my old hosting to the new hosting.

I have started to use personalized name servers.

My new IP Address is {redacted}, and I have changed all of the old IP References to {redacted}.

But, still, Cloudflare tries to redirect the web browser to the old IP Address which is

In this case, how can I solve this problem?

  • I still use Cloudflare Name Servers.
  • I have changed all of the IP Addresses from Cloudflare’s DNS Management Dashboard.


Thank you for asking.

This one is the Cloudflare IP.

If the DNS records (hostnames) are proxied and set to :orange:, it’s normally to see an IP address from the Cloudflare network.

Otherwise, may I ask if you tried to click on the “Purge Everything” button by navigating to the Caching → Configuration at Cloudflare dashboard for your domain name? :thinking:

Nevertheless, if you scroll down a bit on that tab, what option and value have you got selected for the dropdown menu under the “Browser Cache TTL”? :thinking:

Set it to “Respect Existing Headers”.


Thanks for the answer, Fritex.

I believe I have conveyed the problem with some missing parts.

When I start to use Cloudflare nameservers, it starts to tell “Too many redirections”.

I believe if you check the image, you will be able to see that there is an “orange cloud” picture that mentions that the everything should be fine.

Thank you for feedback.

In the meantime I’ve updated my answer, please check if related to the cache too.

Nevertheless, in terms of:

May I just drop this article here:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect
  4. Then make sure site is working as expected with HTTPS without any HTTPS/SSL error.
  5. In case if not, kindly review with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot to renew your SSL certificate and make sure it’s a valid one for your domain name
  6. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

From the provided screenshot, please consider switching the A mail from :orange: to :grey: (DNS-only) to make sure your e-mails continue to work while using Cloudflare for your domain name.

And also check if the MX hostname contains the target to that hostname which is set to :grey: (DNS-only).

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:


Thanks for all of the answers, suggestions, and information that you have provided.

I can convey the process as below:

When I have sent this email, it was “Off”, but there were other options that are selected such as HTTPS Rewrite, Enabled HSTS, Certificate Transperency.

At the moment, I have turned all of them off. It is still not open.

And, I have tried the curl command, it shows a 301 Status Code.

I have an SSL Certificate on my VPS. I have also updated it 2 hours ago. It uses ZeroSSL.

I have changed the changed the email section as you wanted.

1 Like

When I check the SSL at your origin via below command (just change the IP):

  • curl -svo /dev/null --resolve

I also see 301 Redirection, but seems like the redirection comes from the WordPress:
X-Redirect-By: WordPress

And you are also using Cloudflare APO for WordPress:
cf-edge-cache: cache,platform=wordpress

May I ask you to manually clear the cache using the APO + Purge Everything at Cloudflare dashboard? :thinking:

1 Like


Your last suggestion solved all of them.

Thank you! I will send this information to the Namecheap support team as well, it can be beneficial for future candidates.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.