Cloudflare-dns.com/dns-query does not work

I am trying to implement this dns-in-google-sheets.md

and it seems that the cloudflare-dns.com/dns-query don’t work anymore

https://cloudflare-dns.com/dns-query?name=google.com&type=A
Returns 400

Any idea?

Works for me:

curl -kvH 'accept: application/dns-json' 'https://cloudflare-dns.com/dns-query?name=google.com.com&type=A'

{“Status”:0,“TC”:false,“RD”:true,“RA”:true,“AD”:false,“CD”:false,“Question”:[{“name”:“google.com.com”,“type”:1}],“Answer”:[{“name”:“google.com.com”,“type”:1,“TTL”:300,“data”:“199.59.242.154”}]}%

Thanks! mmm. Indeed through CURL !

BUT not in my Google Sheets script as in https://github.com/cloudflare/cloudflare-docs/blob/production/products/1.1.1.1/src/content/fun-stuff/dns-in-google-sheets.md

Or directly in Chrome browser, nothing is returned for me. 400

Not that I’ve ever used it before, but I just followed the instructions from https://developers.cloudflare.com/1.1.1.1/fun-stuff/dns-in-google-sheets and it worked just fine.

1 Like

WAH! And do you mean that if you call this URL in a browser you ALSO get a return?

https://cloudflare-dns.com/dns-query?name=google.com&type=A

On my end, I get nothing.
Am I blocked!? Is there a special DNS setup I need to have on my computer?

I get this
–2021-01-08 16:25:22-- https://cloudflare-dns.com/dns-query?name=google.com
Resolving cloudflare-dns.com (cloudflare-dns.com)… 104.16.249.249, 104.16.248.249
Connecting to cloudflare-dns.com (cloudflare-dns.com)|104.16.249.249|:443… connected.
HTTP request sent, awaiting response… 400 Bad Request
2021-01-08 16:25:22 ERROR 400: Bad Request.

No, but I don’t expect to either. The sample code includes the dns-json bits that should formulate a correct call if you simply copy and paste.

That’s clearly not being executed from Google sheets. So you should fix whatever code is making that request.

Thanks for your help! I was able to make it work. Indeed it was with my function and notthe page that was the culprit.

PS: But I really felt this URL should have worked. What is the FINAL https url that would return the array? Can we call directly?

Thanks again!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.