Cloudflare DNS blocking YouTube?

I used to set my DNS to Clouflare for Families (1.1.1.2), on both IPv4 and IPv6, at the Windows settings on my PC and never had any trouble with it.

Now I tried setting those on my router, and suddenly issues arised.

On my PC (which still has Cloudflare DNS on Windows settings) everything works fine.

On my girlfriend’s work laptop (of which she’s not an Admin and has Windows set to obtain the DNS address automatically), YouTube videos won’t load. The page loads, search works, but videos keep loading… and never do.

When I set my PC to obtain DNS automatically, YouTube videos stop loading on it too.

When I set my router back to the default DNS settings, everything goes back to normal.

Does that make sense?

Am I missing some setting to make things work? Does Cloudflare DNS need to be set on both the router and the PC? I’d like to keep those DNS settings on the router so I can use Cloudflare on every device connected to it without having to change DNS settings individually.

I tried searching around the web and found nothing. Any ideas?

Thanks!

When your pc is set to obtain DNS automatically (ie. through DHCP), and not working, can you paste in a ‘ipconfig /all’
(Just looking for the ‘DNS Server …’ Section)

Do you see the device getting the correct DNS Servers and/or your router’s IP?

Perhaps your router has DCHP Configuration page, does this have the correct DNS server IPs?

This is what my ipconfig/all looks like. As I expected, the DNS Server is the router’s IP. I couldn’t find any DHCP Configuration on my router settings.

I find it weird that the only issue I’m having (as far as I have noticed) are YouTube videos not loading.

Ethernet adapter Ethernet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) Ethernet Connection (11) I219-V
Physical Address. . . . . . . . . : 3C-7C-3F-50-2E-1D
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2804:431:c7c0:99ec:c43d:976b:b91f:9715(Preferred)
Temporary IPv6 Address. . . . . . : 2804:431:c7c0:99ec:e41e:fd70:a732:6016(Preferred)
Link-local IPv6 Address . . . . . : fe80::c43d:976b:b91f:9715%5(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.15.26(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : quarta-feira, 11 de agosto de 2021 21:43:33
Lease Expires . . . . . . . . . . : sexta-feira, 13 de agosto de 2021 00:40:15
Default Gateway . . . . . . . . . : fe80::a633:d7ff:fefa:daa7%5
192.168.15.1
DHCP Server . . . . . . . . . . . : 192.168.15.1
DHCPv6 IAID . . . . . . . . . . . : 524057663
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-28-7A-82-A1-38-68-93-7F-AD-5F
DNS Servers . . . . . . . . . . . : fe80::a633:d7ff:fefa:daa7%5
192.168.15.1
fe80::a633:d7ff:fefa:daa7%5
NetBIOS over Tcpip. . . . . . . . : Enabled

Perhaps a workaround would be to find the DHCP configuration page in your router and get it to pass on the DNS servers.

I’ll be sure to try that.

But is it not weird that the issue is limited only to loading YouTube videos?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.