Cloudflare default setting (Plan: Free Website)


#1

Hello dear Cloudflare community,

I would like to know if there is a way to reset the Cloudflare setting (Plan: Free Website). Unfortunately I messed up pretty much with the options and I keep getting the same “TOO_MANY_REDIRECTS” error.

I tried to delete and re-add a brand new website but Cloudflare seems to save those previous settings.

Thank you ! :wink:

Cheers from France !


#2

Sorry, no. But I’d make sure of the following:

  • SSL is set to Off (Crypto Tab)
  • Get rid of all Page Rules
  • Turn off anything that says HTTPS in Crypto Tab

That will probably fix the Too Many Redirects. If you have more questions, post the domain name.


#3

Hi Sdayman,

Thank you for your quick reply.

Actually I bought my domain name on Namecheap, then I pointed it to Inmotion Hosting (by using the Inmotion Hosting nameservers).

But I wanted to speed up my website using the free Cloudflare CDN. So I replaced again the nameservers (on Namecheap) by the Cloudflare nameservers.

Since that, I constantly got the same “TOO_MANY_REDIRECTS” error.

I will try to follow your advices and I will get back to you.

My domain names is : theduvietnam.fr

Thanks ! :wink:


#4

Sdayman,

I did everything you told me :

  • SSL is set to Off (Crypto Tab)
  • Get rid of all Page Rules
  • Turn off anything that says HTTPS in Crypto Tab

But unfortunately I’m still getting this “ERR_TOO_MANY_REDIRECTS” as you can see here : https://theduvietnam.fr/

Do you think that I have to disable also the “TLS 1.3 BETA” and the “Universal SSL” located in the Crypto Tab?

I also forgot to tell you that I already use the “Inmotion Hosting SSL Certificate” that I want to keep. So perhaps there is some kind of conflict ?

Sorry but I am really a novice.


#5

Ah, with the SSL certificate, try setting SSL here to Full (Strict). Don’t change any of the other settings…yet.


#6

Sdayman,

I tried to put SSL to Full (Strict) as you told me.

Unfortunately it breaks all my website css.

I just turned off the Cloudflare SSL certificate.

I will wait a little bit and we will see when the changes will take effect.

Thank you


#7

Can you turn it back on? I’d like to see how the CSS breaks.

p.s. The good news is that you no longer get the Too Many Redirects error.


#8

Its Ok, I just turned it back on full (strict).

As you can see here (https://theduvietnam.fr/), my wordpress theme don’t really like the cloudflare SSL.

I think you will have to refresh a few times to see that it breaks everything.


#9

It looks like HTTPS is working, and I don’t see any CSS errors. Is the footer section supposed to be dark?

The rest looks good.


#10

And that’s how it looks from Safari, Firefox, Chrome, and Pingdom’s page test:


#11

It’supposed to look like this actually :

Here’s the footer :

The shop page :

And the blog page :

I took theses screenshots from my local backup (wamp) so a few things changed since this, but the menu and footer should look like this.


#12

So here’s what I will do :

I will turn off the Cloudflare SSL certificate.

I will wait a little bit and see (because this morning when I checked everything seemed to be perfect with the Cloudflare SSL certificate turned OFF, but I think it takes times like 24h)


#13

Other than the different background image in the front page header, that header and footer match what I saw.

I did not check out the Shop page, or the Blog, but I just didn’t see anything that was broken.

Now it’s giving me Too Many Redirects.


#14

Now I got the error TOO_MANY_REDIRECTS but i think it will be fixed in a few hours.


#15

I thought it was OK when I last checked it. I don’t expect the Too Many Redirects error will go away. That is usually an indication of an HTTP to HTTPS to HTTP infinite loop.


#16

Hello Sdayman,

You’re right. I thought the error will stop by just waiting all night long but it didn’t work either.

So I change back the nameservers by the inmotion hosting ones and I remove my site from the cloudflare dashboard.

I think that perhaps the combination of Namecheap + Inmotion hosting + Cloudflare ins’t working.

Thanks for your help anyway


#17

This topic was automatically closed after 14 days. New replies are no longer allowed.