Cloudflare Dashboard Giving 403 Forbidden Error

When I log into the Cloudflare Dashboard and click on my domain to manage, I am instantly greeted with a 403 Forbidden error message. This is, again, directly from Cloudflare(dot)com within the Dashboard itself, I’m not trying to access my subdomains (which I can still do just fine).

I wanted to add another subdomain through Cloudflare but I now cannot manage any of my site’s settings. I’m concerned that security may have been breached for my dashboard. I tried opening through a Private/Incognito window, no luck. Haven’t tried accessing through VPN yet.

UPDATE: Subdomains are available, but the Dashboard gives me this: “403 | You don’t have permission to view this page.”

Are you the only user on the account, or could someone have removed permissions from you?

I am the only user on the account. I was even able to change the password earlier today. I just checked in case whatever was wrong had cleared up, but no, there’s still the 403 error on the dashboard.

Please make an account ticket here. Please let me know the ticket number so I can escalate it.

Ah, well, I am apparently part of the free plan, and the link says “Customers on our Free plans can only submit tickets for billing, account, and registrar issues”. I don’t think I can submit a ticket.

Wait, sorry, I just realized you said to make an account ticket. My apologies. I shall attempt it.

I have successfully submitted the ticket: 2628202

I have escalated your ticket.