Cloudflare "Checking if the site connection is secure" Loop

Answer these questions to help the Community help you with Security questions.

What is the domain name?
billing {DOT}sparkedhost{DOT} com

Have you searched for an answer?
Yes

Please share your search results url:

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?
https://community.cloudflare.com/t/cloudflare-checking-if-the-site-connection-is-secure-and-site-spins/434296

Describe the issue you are having:
It will not allow Brave Browser to work at all. Microsoft Edge works fine. With Brave, it just sends me on a loop, even though I disabled adblock. This happens regardless of using a VPN or not,
It’d be great if it didn’t get in the way of my browsing experience with Brave. It’s very inconvenient opening up another browser because Cloudflare is allergic to Brave Version 1.45.123 Chromium: 107.0.5304.110 (Official Build) (64-bit)

What error message or number are you receiving?
N/A

What steps have you taken to resolve the issue?

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?
Tried on Edge: Works.
Tried on Brave Incognito: Doesn’t work

Please attach a screenshot of the error:

Have you confirmed that Brave isn’t removing cookies after solving the Challenges? It could be that:

  1. The browser is spoofing something after solving a challenge and Cloudflare invalidates the cookies.
  2. The browser isn’t keeping the cookies after the challenge is solved.
  3. The browser is blocking the challenge answer submission.

Other browsers not failing kind of discards the IP being an issue, so its either a false positive from CF or the browser doing something it’s not supposed to.

Can you dump the requests that occur while solving the challenge? a HAR file would help.

I’ve had to store them on OneDrive.
I’ve attempted it twice, and have included the second one.
https://1drv.ms/u/s!AgJ9Z52-HKAqgqZnk_iN5orWfEVHyQ?e=gnbWgR
As far as I can tell, it isn’t keeping the cookies after it’s solved, as they’re gone when the page automatically refreshes.

Hi @hbidamian, could you open the page in Brave, capture a .HAR and attach it?

You can do so by opening Developer Tools, going to the Network tab and clicking the Export HAR button.

This post was flagged by the community and is temporarily hidden.