Cloudflare cert showing instead of site cert in Full (strict) mode


#1

When I added my site to Cloudflare I selected Full SSL, even though I already had a certificate. After reading documentation I switched to Full (strict), but several days later I still see the “Verified by Cloudflare” when I hover over the lock to the left of the URL (Firefox).

There are no errors and Universal SSL Status is “Active Certificate.”

Do I need to do something to trigger certificate reloading? Maybe switching nameservers back to the original and then back to Cloudflare?


#2

Cloudflare acts as a Proxy, which decrypts your data and then re-encrypts it with its own certificate.

This allows CF to do Minification, firewall, etc. If you want your own certificate showing up instead of the CF certificate, you’ll need to disable the proxy (by setting that DNS record to :grey: cloud) which will also disable ddos protection, firewall, minify, etc.


#3

Thanks Judge - makes total sense. I was getting an SSL handshake error on a Nagios monitor and was looking in the wrong spot for the fix. Pointing Nagios to the original IP fixed the issue.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.