Cloudflare causing blank pages

I am having issues with this WordPress website when Cloudflare is enabled.

every page is loading with all the content missing when it first loads,but if I then reloa dthe page it is page. This happens on every single page on every single visit.

If I bypass Cloudflare, the issue does not happen.
however I have already tried disabling all the caching/speed options in CF, so I don’t know what is causing it.

If it helps I am using the BRIDGE theme from Qode… some Googling has shown that this theme seems to have some issues with caching, but as I said, I have disabled all the options in CF, so don;t know what is causing it.

Auto minify is disabled
Rocket loader is disabled
Brotli is disabled

It sounds like you’ve been pretty thorough.

I tested in Firefox and Brave (Chrome) and everything loads first time on both browsers. I checked Home, About, News, and a few products.

Please check your browser’s Dev Tools (F12 in Chrome) for any error messages under the Network and Console tabs.

yes when the page first loads, I get errors, when I reload, no errors.
what would cause that?
and yes I have tried incognito window

I don’t get that many errors, my DEV tools show this

Currently, I don’t get this issue in my Web browser while visiting your Website thinking:

I can see you’re using WPBakery Page Builder Plugin to show the content, which might cause some issue as far as it’s using Ajax in the background and doing tasks which could add some CPU load and similar if you’re using a shared hosting :thinking:

Nevertheless, you’re using Litespeed and it’s caching system, which might compress the content on the origin host and not showing it as it should be (similar issue I had with WP Super Cache plugin).

However, I have had similar issues like you described, but before I started using Cloudflare. It was un-optimized origin host / my VPS server and a bunch of traffic hitting it.

Therefore, some “whitespace” errors as an output of the WordPress XML also which I found by troubleshooting my plugins and similar, which I finally fixed using below:

If you think it’s a Cloudflare, then kindly I’d suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at
The link is in the lower right corner of that page.
Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Meaning, I am afraid it has to be something with your origin host / web server.
Kindly, I’d suggest you to try troubleshoot this on first with your hosting provider.

Enable WordPress Debug mode, switch off all plugins, check XML errors and for whitespaces, change theme, check PHP settings, etc.

Might be a bit out of the scope for this forums, if so.

Other helpful ideas:


Pausing Cloudflare would seem to do the same thing.

What about the Network tab? If you’re getting a 404 on that logo.png image, it makes me think there are other things not loading.

It’s interesting, the theme is having some kind of like, the main menu is using the history API to navigate the web browser, while the inner pages are normally linked :thinking:
And there is an effect of “fade loading” of them.

thats the only 404 I get, although the logo is loading fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.