Cloudflare causes Wordpress scripts to timeout

Hello everyone.
I am new to Cloudflare and I have some issues.
I am running WordPress (WooCommerce) with scripts that require a lot of server and PHP memory.
These scripts run sometimes for 10+ hours.
When I have Cloudflare enabled, they get interrupted after a couple of minutes.
When I disable it, they run just fine.
I would like to have Cloudflare enabled all the time, but without any limitations on my script (plugin) execution time or resources.

How can I set this up?
A step by step guide would be great. Thank you!

May I ask if the origin host/server is capable of executing this?
Is it a dedicated server or shared hosting?

Cloudflare’s default timeout for HTTP(S) request is 100 seconds.
Timeout increases are only available to Enterprise plans.

What kind of request(s) does it send?
Is it Ajax or?
Are you doing them via cronjob, or WP-Cron, if so?

Hello.
It’s a XAMPP setup.
The server is capable of executing them and has enough resources. It does it fine with Cloudflare disabled.

The timeout of 100s is the explanation. This is exactly how long it takes before my plugins are interrupted.

Ajax

Configure your processes to communicate with the server on the server locally and not proxy through Cloudflare.

1 Like