Cloudflare can't catch nameserver update

I have changed my nameservers in the domain hosting company but it has been days but there is still no update in Cloudflare. May I know what could be the issue

You most likely did not change the nameservers correctly. What’s the domain?


I have double checked multiple times

You set the Cloudflare servers all right, but you still have the Amazon ones as well.

should I have to remove those?


On top, you don’t have a valid SSL setup on your server and that won’t work either. Before you do anything with Cloudflare, make sure your site is correctly configured.

1 Like

I have removed those nameservers from amazon. I hope it would work but I have waited for few minutes but still there is no sign of change…

Oh and I am actually wanting Cloudflare for my SSL setup and seems like this process of setting my nameserver seems a necessary process

I am afraid that’s not how it works. Your site needs to be secure independently of Cloudflare. You need to have a valid certificate on your server.

Oh problem solved!!! Thank you so much. I didn’t know it would be a problem if I have multiple name servers

I don’t think the issue is fixed. You still appear to have no certificate.

Closing this topic as the original question has been answered and resolved.