Cloudflare blocks Wordfence

Hi,

I have deactivated Cloudflare on 4 of my websites due to the following reason.

It seems that Cloudflare is blocking the WordFence servers from communicating with my websites. I am getting the following error when having CloudFlare activated on my domains.

“Warning: Cannot modify header information – headers already sent by (output started at /home/mysite/public_html/wp-cron.php:28) in /home/mysite/public_html/wp-content/plugins/wordfence/lib/wfUtils.php on line 1674”

And this on the Connectivity debug tool:

“wp_remote_post() test back to this server failed! Response was: 503 Service Unavailable”

Please check this issue, I cannot use your service until this has been fixed.

Thanks.

Cloudflare doesn’t block Wordfence in default configuration. I use Wordfence on all my WordPress sites.

That first error looks like you may have set some headers, either with another plugin, or something in Cloudflare. But I don’t know which header that would be.

When you say “connectivity debug tool”, do you mean this:

5xx errors generally come from the web host, so check the server logs and host support

Hi,

Indeed CloudFlare is blocking the Wordfence connection. When I have it enabled on my sites, the “Connecting back to this site” is showing the error that I mentioned above.

I have also added a rule to allow the wordfence ip address, but no luck.

There is nothing on my server’s logs, please note that the last 3 days that I have deactivated the Cloudflare the Connectivity works pretty fine.

This topic was automatically closed after 30 days. New replies are no longer allowed.