Cloudflare blocks joomla 4.0 drop down menus

Answer these questions to help the Community help you get started.

Domain name is
Yes, I searched, nothing specific.

diagnostics just fine.

If I am in developer mode (or pause Cloudflare) Joomla 4.0 dropdown menus work just fine.
Once I disable developer mode and try from a new browser, dropdown menus don’t work.
I tried disabling Cloudflare cache with this ‘page rule’*
Cache Level: Bypass"

What steps have you taken to resolve the issue?

  1. turn on developer mode, turn it off
    2.pause Cloudflare, unpause it
  2. disable cache with page rule.

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. enable Cloudflare and disable developer mode

Have you tried from another browser and/or incognito mode?
yes, doesn’t make a difference.
(but, strangely enough, if I go to a page that doesn’t exist, get a 404 error, THAT page (for a while) drop down menus work.
only thing that works is to either turn on developer mode (which expires) or pause Cloudflare.

I hesitate paying for service since I don’t know if that will even fix it.

i tried everything, and even did a diff -bBru on ‘good’ page vs bad. NOTHING in the source, so it has to be something my chrome browser (with no plugins) is or isn’t sending.

code make no sense, this
but when i open ‘inspect’, i see ::after in the good one, and ::before ::after in the bad one.

it was ‘autominify’ javascript to fix Joomla 4.0 drop down menus
I turned it off for the whole site and it works.
css had the ::before and ::after, and also, 4SEO has similar inside of php, so, MAYBE you could minify java, but i spent 5 days doing this, and it still seems ‘random’.