CloudFlare blocks Direct IP access of my wordpress website instance running on AWS

I cann’t access the log-in page of wordpress admin. It seems that the problem is cloudflare blocks the direct IP access when using http://PublicIpAddress/wp-login.php. It shows server not found error. I have contacted bitnami support team and they indicated that cloudflare shows 1003 error. How to solve this issue please . I am running my website through AWS lightsail instance.

You can’t use Cloudflare’s IP addresses directly. You need to reach them via hostname. Why aren’t you using your domain name for wp-login?

Hello sdayman, Actually I wasn’t the one who set that. It is my company website and it was set mistakenly by someone else. Nevertheless what would be the solution for that problem. When I try to access using my domain name for wp-login I will be redirect to another page in my website.

Hi sadayman,
Just an update apart from previous issue. I have edited in my wp php config file by changing
define(‘WP_SITEURL’, ‘http://’ . $SERVER[‘HTTPHOST’] . ‘/’);
define(‘WP_HOME’, ‘http://’ . $SERVER[‘HTTPHOST’] . ‘/’);

to

define(‘WP_HOME’,‘http://proceedit.com’);
define(‘WP_SITEURL’,‘http://proceedit.com’);

But my website is showing blank page even after recovering the original state of the file. The bitnami support team indicated that [ Right now the proceedit.com domain name is pointing to the IP 104.18.33.190
However, according to the latest bnsupport code your external IP is 3.122.5.129
Do you know the origin of this discrepancy? I am not familiar with CloudFlare but I think this is related to be using CloudFlare.]
can you help with this issue to recover my website to function as usual . It is now all blank page www.proceedit.com

Cloudflare is a Reverse Proxy, so it’s like a firewall for your website. That IP address is Cloudflare’s reverse proxy server, which makes the connection to your own server.

What’s interesting is that there’s a working login screen if you try to access wp-admin. And it’s not the wp-login system, so there’s some custom configuration set up.

If you want to untangle this, go to the Overview section of the Cloudflare dashboard and click “Pause Cloudflare on Site” in the lower right corner. That will bypass Cloudflare and let you troubleshoot directly on the site.

Hello sdayman,
I have removed my website proceedit.com form Cloudflare but now my website is showing Secure connection failed error. what would be the cause and the solution?

This topic was automatically closed after 14 days. New replies are no longer allowed.