CloudFlare Blocking SemRush crawl

Hello, I tried to crawl my website (https://1droidmods.com) on SemRush. But CloudFlare is blocking tracking. Below the error message:

SemRush gets to my sites without blocking. Have you checked your Firewall Events Log for this access atempt?

p.s. Don’t count on ‘curl’ being a good access test. I run across many people’s sites that block my curl requests, but don’t block regular browser requests. :man_shrugging:

I disabled the firewall but the problem continues :frowning:

Parece que os endereços IP da SemRush estão em Blacklist (Lista negra). Os 3 IPs estão apresentados na imagem acima. Poderia remove-los da Blacklist por favor? Obrigado.

I’m a Cloudflare customer and have no access to your account settings or internal configurations.

Have you tried adding those three IP addresses to Firewall -> Tools in the Allow list?

I got the same problem just today - I tried to add those three ip addreses in cloudflare’s firewall (firewall -> tools with allow list) and the site becomes unreachable like it returns 503. What’s happenning?

If adding them to the Allow list doesn’t let Semrush through, then I suggest opening a Support ticket. Let them know the IP addresses that are failing. The image from the original post would also be helpful for Support to see.

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

Yes, I already tried to allow the 3 IP addresses and I left a few hours, but it also didn’t work.

Before joining CloudFlare I was able to do the tracking on Sem Rush. From May, when I joined CloudFlare, that was no longer possible.

I have contacted CloudFlare and will be waiting for a response. Thanks for trying to help.

This topic was automatically closed after 30 days. New replies are no longer allowed.