Cloudflare Blocking re Captcha V3

Everything had been working fine but now Cloudflare seems to be blocking ReCaptcha on my website preventing elementor forms from being submitted with a connection to recaptcha error. If I go to development mode, then everything works fine again. This is actually now happening only on all my websites using Cloudflare. The non-Cloudflare websites seem to work fine.

Is there a rule set I can enter? Specifically what would it be?
And yes I tried turnstiles plugin for wordpress but it has way too many bugs at this stage.

Are you restoring visitor IPs?

Not sure how that is done - on Cloudflare? on server?

Documented here, Restoring original visitor IPs · Cloudflare Support docs

Thank you
Will see if this works! Appreciate the help

1 Like

The other thing to investigate is if you’re blocking elementor. My theory was elementor forgot I’m user 123 because my IP is not restored and hence I get the challenge again. It could be simply that the elementor IP is being blocked, you should be able to see that in your firewall activity logs, If so, you’d create a rule to allow those IP via the cf dash. That is probably an easier approach and may be worth investigating first.

I had actually done that before psoting to this forum. I create rules to allow for Wordpress and Elementor.

1 Like

So, I verified all the rule sets with elementor tech and I have them correct.
I also verified that Wordpress rules were also correct.
I followed the article for doing restoring Ip’s using mod_remoteip
one minute it works
and gthen the next captcha says it cannot connect

I am at a complete loss now.

1 Like

Let’s try to rule out the firewall by temporarily disabling the Firewall in the Cloudflare Dashboard. Navigate to Firewall > Settings > Firewall settings > Security Level, then set it to “Essentially Off.” This is not a permanent solution, but it will help figure out if the Firewall is the cause of the issue.

So with CF firewall set to essentially off, I am still getting “Can not connect to the reCAPTCHA server (0).”

I have also checked the origin server mode sec rules/tools and the CSF firewall on the server, but it is not showing any incidents.

Did what I should have done initially, :search:

Some ideas in those threads, but you’re not running APO so I suspect it is something with the wordpress configuration, similar issue reported on a wordpress site

Will check the article out. this is a shared server and I have another site using elementor, CF and Captcha and it is NOT having any issues. So weird

1 Like

oh yes, that does make it tricky

Is it the same version of elementor and are cache settings in cf the same?

So I have CF rules as follows (just omitting site url here)
Disable Security, Cache Level: Bypass, Disable Performance for


I also have white listed the server IP as well as the dedicated website IP

Yes, settings are identical

So on the site that is having the issue -
If I send the form and get the connection error and try again the connection error continues
If I leave the form for 15 minutes and try again it goes through
So some weird time out or reset period?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.