Cloudflare blocking images in emails 2

I have the same problem as on this topic: Cloudflare blocking images in emails and I couldn’t solve either, no images are displayed in my emails, I disabled hotlink and created a whole bunch of rules but none worked I also tried to set the security to minimum (minimum under attack mode)

thank you for your help it’s been 2 hours already…

Especially since before it worked well, and it works if I first go to my site, pass Cloudflare then come back to my html page and on the emails it never works…

When you get one of these blocked images, what is the server responding with exactly? Can you check DevTools to see what the image response is?

Hotlink protection is the obvious culprit here, but if you have that disabled I’m not sure what else it could be yet. Do you have any other rules setup that are adding any headers to images?

The message in the console is Failed to load resource: the server responded with a status of 503 ()

I tried these two rules
(http.request.uri.query eq “https://www.mysite.com/Newsletter/logo_site2.jpg”)

(http.request.uri.path eq “/Newsletter”)

Thank you

This works when Under Attack Mode is disabled. How to have both please?

You shouldn’t leave Under Attack mode on permanently. It should only be used when you’re actually under attack. It will cause temporary issues with things like analytics, bot crawling, etc. and almost certainly image links too as you’re seeing here.

https://support.cloudflare.com/hc/en-us/articles/200170076-Understanding-Cloudflare-Under-Attack-mode-advanced-DDOS-protection-

1 Like

Ok I left it on high and it works! Thank you !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.