Cloudflare blocking Google

My Google Merchant feeds come up with the error “Download failed due to authentication error. Please check username and password in your feed configuration and try again.” And it turns out that the CloudFlare Super Bot Fight Mode is the problem. I have the Definitely automated set to challenge, and that blocks Google. Please fix it.

IP for Google blocked is

May I ask if you are using some Firewall rules or security options at Cloudflare dashboard for your domain?

Moreover, can you try adding that IP address to IP Access Rules at Cloudflare with action “Bypass”. In case if needed, also to Firewall Rule with action “Bypass”.

After adding, wait for few minutes to apply the changes and re-check?

Try having it like (Allow here):

Or even better (bypass security level in Firewall Rule - add it to the top, make it be 1st rule due to priority order):

It’s as if you didn’t read what I typed at all. I’m seeing it for multiple IP’s all starting with 74.125.191
I just changed Definitely automated set to allow, seems the bot fight mode isn’t ready for prime time yet.

Have you checked with similar topics using :search: ?

What about adding an Google ASN number to Allow at IP Access Rules/Firewall rules (bypass option)?

May I ask if you have tried contacting Google about this issue?

Yea if you are certain that this block is due to Super Bot Fight Mode, then the only option you have it to set the actions to allow, as you’ve already done. Unfortunately, IP Access or Firewall Rules would not allow you to whitelist an IP if SBFM is blocking the request.

There’s been much discussion in the community around this limitation, take a look at this thread for reference: Questions About Cloudflare Super Bot Fight Mode


This is a horrible thing to do to a small business like mine. I got emails about this great new bot fight feature, and I turned it on assuming it was working properly. It’s clearly not, and no warning is given about this type of situation happening. Actually on the contrary, Cloudflare says it knows verified bots and lets you allow them. I also am frustrated with Google lack of a proper error message. I have wasted so much time on this today. Not a happy customer right now. – And the answer from the Cloudflare Team is to read another thread instead of updating the bot fight feature. Not a good sign.


I’m getting the same regarding my google merchant center feeds failing i.e. product feed .txt files can not be retrieved by google merchant centre.

In my case turning off “Static resource protection” in the Super Bot Fight Mode appears to have fixed the issue.

Which files are protected?

Cloudflare defines static resources as files with the following extensions: |css|jar|js|jpg|jpeg|gif|ico|png|bmp|pict|csv|doc|docx|xls|xlsx|pdf|ps|pls|ppt|txt|ico|pptx|tif|tiff|ttf|otf|woff|woff2|webp|svg|svgz|eot|eps|ejs|swf|torrent|midi|mid|

This topic was automatically closed after 29 days. New replies are no longer allowed.