Cloudflare blocking file upload intermittently, can't find match for Cloudflare Ray ID

Have you searched for an answer?
This looks like it’s highly relevant, but mine has only happened for a tiny percentage of users when uploading specific files. Cloudflare blocking uploads with some file extensions - #2 by fritex

Describe the issue you are having:
On rare occasions, users of my file transfer app are blocked by Cloudflare. It is specific files that are triggering the blockage, as users are able to transfer other files without issue. Some have been able to get around the blockage by making modifications to the file (which is usually either pdf, xlsx, or docx, not macro enabled.) That has not worked as of yet in this latest occurrence.

What error message or number are you receiving?
Sorry, you have been blocked, with a Cloudflare Ray ID. I have presented this ID to my network team and they are unable to find a match.

What steps have you taken to resolve the issue?

  1. Some users have found modifying the file works
  2. We have also tried zipping the file
  3. I have also suggested renaming the file

What are the steps to reproduce the error:

  1. User logs into application through SSO portal
  2. User navigates to file share screen and attempts to share file
    I would note that this is the main function of the application, and less than a handful of users have experienced this error.

Have you tried from another browser and/or incognito mode?
Yes, with the same results

Since I don’t have access to Cloudflare or a method for replicating the error, I suppose I have two questions:

  1. Why can’t my network team find the Cloudflare Ray ID? I provided the screenshot from the use with the ID, which came from less than an hour prior to the search. It seems like if they could find the ID they could identify what specifically triggered the block.
  2. Are there other rules in addition to the OWASP ruleset in the linked topic that I should look out for?

Thanks for your time!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.