Cloudflare blocking Ahrefs bots/IPs from crawling my site for a site audit?

Basically what the title says. I cannot get Ahrefs to crawl my site for their SEO audit. This is the error that is returned to me on their site:
“The HTTP server returned error 403: “Forbidden”. This request was likely filtered by server configuration. This website is protected by the Cloudflare firewall”

I talked with their support and they confirmed Cloudflare was blocking their bots. I whitelisted their IP range in the firewall settings along with allowing their user agents, but I still get the 403 error from Ahrefs.

Any idea what’s going on here and how it can be fixed?

Can you please post a screenshot of your firewall rules?

Hi there,

I’m having the same problem.

Here’s the IP ranges the Ahref bot uses:

And here’s my current firewall rule:

Can someone help me?

Thanks and regards,

That won’t work since their IP ranges are in a CIDR format. The following should work:

(ip.src in {})

But I think it would be better to create an IP access rule instead of wasting one of your firewall rules. You should be able to create 7 rules in total to whitelist all 7 of their IP ranges.


Thanks, Judge! Appreciate your fast response.

Just tried to run another crawl and still get the same error (403). Do you have any other ideas on how I could try to fix this?

This topic was automatically closed after 14 days. New replies are no longer allowed.