Cloudflare Billing Failure every start of new Period

Hi Cloudflare.

In the last months Cloudflare failed everytime
to bill my creditcard for some strange reason.

Whne i Log inside the dashboard i get the information about a open invoice
every time a new period starts however after 1 or 2 days the problem get resolved automaticly
and the payment is successfull.

Also when i try to add paypal as a backup solution i get the sms code
i write it and paypal successfull finish the process
but then on Cloudflare side nothing happens.
the paypal back up solution is not added and showed.

Your Billing is since months broken i hope you know this !
Billing does not work and paypal backup solution is not added on the Cloudflare side even paypal verify it successful.

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with the billing for your Cloudflare account.

May I ask if your e-mail address associated with your Cloudflare account is verified and you passed the verification process? :thinking:

Kindly send an e-mail to billing[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account and share the ticket number here with us so we could escalate this issue.

May I tag @Laurie to check this when available.

2 Likes

Hi @seoworks,
I checked both your account and our payment processor and am seeing that the same day your monthly invoices are generated the payments are being processed. If you have a specific invoice this is regarding please send that in a ticket and we can further investigate.

2 Likes

Thank you @fritex and @Laurie

I checked now the status of the last billing and it got resolved on its own like
all the last billings that were showed in the dashboard as open after a 1 to 2 days.

Not sure why this happens.

Could it be related to different time zones that it shows in the dashboard as open
every time at the beginning of a new period.?

I am +10 to PTC Time Zone.

The last billings were always showed to be open when i logged in and got solved in about 1 day
on its own withut that i have done anything.

Problem for now is solved again.

Lets hope it never show up again.

Thanks a lot.

1 Like

@seoworks,
Our billing is all in UTC time so yes it could be.

2 Likes

Thanks for the clarification @Laurie

I just had to use the Credit Card that is linked with my Cloudflare account
and was reminded that the CreditCard has 3DSecure enabled.

Normaly after each transaction i get a SMS code to my mobile phone
that i need to additional provide for each transaction to be successful.

This could be also probably too a very significant reason
why the transaction fails at the beginning.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.