CloudFlare authoritative name servers not responding


#1

The authoritative name servers assigned to me kim and jerome are not responding DNS queries. Do you experience the same?


#2

I just tried a dig command at those servers and they both responded. Granted, it was via my IPv6 connection, but I suspect IPv4 is just as alive.


#3

I have very confused.
I find that kim and jerome do not respond to my direct lookup requests.
e.g. nslookup mydomain.com kim.ns.cloudflare.com ----> not respond
If I lookup my own recursive lookup server which looks up, kim responds it and I get the result via my recursive server. I observed it via tcpdump port 53.


#4

Are you having a problem with your site? All signs indicate your name servers are working properly.


#5

nslookup (along with dig and some other tools) asks for the answer recursively by default. Try adding “set norecurse” to the query.


Kim.ns.cloudflare.com not answering queries for some locations
#6

Dear all,

Thank you you guys looking into the matter. The problem went away, miraculously.
The problem started 2017-09-20 around 16:25 GMT and ended 2017-09-21 around 11:30am GMT.

Just if you are interested, here are more details. I put it also at ticket #1412897.

I did lookups on my 2 internet uplinks here in my office and my Azure and AWS cloud which are not related at all, so it should not have been my own network problem.

I could not query Kim and Jerome directly (nslookup or dig), but if I query my recursive DNS in my own network, the recursive DNS servers COULD actually get responses from Kim and Jerome (by tcpdump output). So normal end-user lookups should go as usual.
I tried looking up other Cloudflare name servers in *.ns.cloudflare.com , e.g. Bob, Ingrid, etc and all NOT responding.

But interestingly, lookup to ns3,4,5,6,7.cloudflare.com ARE NORMAL. I could even lookup my domain names from them!

I could ping Kim and Jerome all the way.

I tried also on-line DNS lookup tools and they all seem to lookup without a problem.

With those contradicting outcomes I could not even tell where the problem may lie.

The problem disappeared now, so I will let it go. This post is just for your reference.

Thanks again for your effort.

Ken


#7

Hi I’m really stuck with my DNS & SSL my website was live but with no SSL and now it’s 404 I’m not sure what problem is. Do my nameservers look correct? [image exposed origin IPs removed by Cloudflare Staff]


#8

Get this error page


#9

Site appears to be loading for me at the moment. Are you still experiencing issues accessing the site?


#10

I was just about to update you guys. I’ve fixed it now had the wrong IP address. :upside_down_face: long day!


#11

I can’t tell you how many times I’ve made that mistake. That and I once spent 2 hours debugging a problem because I misspelled banana in a CNAME. :crazy_face:


#12

Cloudflare supported replied me that the phenomenan I encountered was due to Cloudflare’s increased security meansure for that period to guard against attacks. Case closed.