Cloudflare appears active, but no content displayed

Answer these questions to help the Community help you get started.

What is the domain name?

Have you searched for an answer?
yes, but i believe i have followed all the suggestions thoroughly

Please share your search results url:

When you tested your domain, what were the results?

This site can’t be reached

Check if there is a typo in : when i try accessing from the computer i’m working on
and when i access it from another mobile device, it says This site can’t be reached. 's server IP address could not be found

Describe the issue you are having:
I cannot get my github pages to run on my domain through cloudflare

What error message or number are you receiving?

What steps have you taken to resolve the issue?

  1. I checked if the page opens up through github’s … This works fine so probably DNS issue
  2. Github Pages says Your site is live at It also shows that DNS Check is successful.
  3. Cloudflare says my site is active. Cloudflare DNS screenshot

Was the site working with SSL prior to adding it to Cloudflare?
not usre what this means, but site launched at

Please help me out. The relavant github repository is
I have the CMAKE file there and it seems fine too

Have you tried from another browser and/or incognito mode?

If I am taking a look at that domain, this is what I see:

… That looks to me to be quite consistent with the content from your GitHub?

If you’re still seeing issues, I’d suspect it would be the DNS resolver you’re using (e.g. your ISP’s) that are still holding the old data in it’s cache, from when your domain did not yet have the CNAME records you’re demonstrate in your screenshot.

Sometimes, DNS can take quite a while to propagate.

1 Like

Thank you for the reply. I tried accessing the domain but it doesn’t show up. I’m not sure why it shows up in your computer though.
I tried accessing with a fresh computer, and it still doesn’t show up. For the current computer I tried clearing the history(and cache consequently) to no avail. are you sure you accessed thhe page through the domain and not the index.html?

I simply entered into my browser’s address bar, and the above was what appeared up at my screen.

I do however use HTTPS where possible, so my configuration added https://, which turned the final address in to

I had no “/index.html” or similar in the end.

Was this fresh computer at the same address / location as the other computer, or … in other words, connected to the Internet through the exact same ISP (Internet Service Provider)?

In a Windows Command Prompt (WinKey+R → cmd), you could try:

nslookup -type=AAAA
nslookup -type=A
nslookup -type=AAAA
nslookup -type=A

On Linux (or other non-Windows) systems, you can try to run “dig” in a Terminal like this:

dig AAAA
dig A
dig AAAA
dig A

Once you have done that, you may share the output here.

You can tag “```” before and after the output, e.g. like this:


To make it become more readable, like this (or as shown with the commands above):

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.