Cloudflare app | WARP connect fail in Belarus and Russia (Win10 + Android)

Hello guys!

First of all I shall say I am a true fan of this solution and the security method seems to be very reliable (I am not a deep spec in this though).

The problem:
Thursday, Dec 2 at around 13:00 (GMT+3) WARP has been disconnected on my PC (win10 x64) but the DNS only mode was OK. Connected via Ethernet.

Mobile app (Android 10 and Android 8) - the same problem exactly. Connected via WiFi and cell as well - the same even on different operators (MTS and A1).

Nothing has been changed on the PC and the phones. It simply started to show me that my connection is not secure. Reinstall did not help on the PC and Androids.

In the console on Android I see an orange string “handlednetworkChange() failed”. The rest messages are green or black, regular.

Collocation is MSQ (Minsk).

The same day Russia has begun blocking of WARP but there are no news on that in Belarus.
Can it be connected somehow?

What else can I check? Could you please also check on your side?

Thank you for any halp

Hi, same here:

My DNS: -

Connected to Teams and Cloudflare SSL instaled, on the devices (PC and Movil)

Не знаю что там блокирует РКН, но в моем случае Ростелеком(бывш. онлайм) молодцы и все ок с варпом, включая рутрекеры. А Билайн засранцы, причем и на мобильном интернете тоже.
У меня в wireshark это выглядит как handshake initiation, а в ответ пустота.
А у вас? Так чисто для сравнения…

Today I connected my mobile to the Internet via the other Wifi and other ISP, so WARP was suprisingly OK.
After that I connected to the Internet via 4G and WARP was OK again.

ISP in Belarus hierarchy is as follows:
Beltelecom - the 1st lvl, the main one - no block, WARP works fine for its clients.
CosmosTV - the 2nd one, lower. - the fail is here.

Cell operators: MTS, A1 - WARP fails. I dunno which of the 2 ISPs are used by the cell operators but it seems to be CosmosTV from what we see.

After I got back to the CosmosTV network, my phone started to fail again with WARP and no way to make it work again. (I have no access to Beltelecom more to try a successful connection).

I have the same problem in Belarus. My provider, Unet, answer that vpn blocked on government level from 2th December.

Will Cloudflare try to solve it?

My opinion is that there is some kind of gentlemen’s agreement, CloudFlare was allowed to raise its node in Minsk, but on condition of blocking the WARP VPN )))
Because before that Warp worked fine through a node in Warsaw…

Cloudflare can do make Warp network ( routing to another DC - WAW (Warshawa) or VNO (Vilnius), as it was before

1 Like

For all users WARP from Belarus: use custom endpoint:

For WARP linux client use:

warp-cli set-custom-endpoint

This network - routed to CF DC in Warsaw )


Thanks bro. But I don’t see such option in iOS app. Is it only available in Android app?

I don’t have an iPhone or IPad to check iOS app

Hey mate,
This is a real solution to the androids I reported above both on wifi and 4G.

However, they may block the address soon as well. Is there a way to pick new adresses up? At least, not quite publicly in order not to disclose them widely around.

The other question is how to solve it on a Windows client? There is no way to change the destination IP.
I tried the downloaded client via a VPN in Switzerland hoping, the client will have another Colocation place (not Minsk) but no - it somehow set the colocation to Minsk again.

That’s interesting about the VPN story!

Could you please provide anysource about that or describe it?
Do you mean WARP+ when you say Warp VPN or I am gettoing you wrong?

Options > Advanced > Connection parameters > User defined endpoint or kinda that. No?

  1. About ip: from my experience - you can try almost any ip address from the range (,, …
  2. I use WARP VPN (without + ) on Ubuntu Linux and Android app

Я писал в A1, они говорят проблема на стороне Cloudflare. На белтелекоме все работает, поэтому не похоже на блокировку внутри страны. Возможно накосячили из-за добавления своего узла в Минске. Предлагаю всем писать в поддержку Cloudflare, чтобы разобрались:

Писал им в support из Android приложения, прикладывал логи - никакой реакции.
Насчет накосячили - возможно, но больше склонен, что есть ограничения от нашего “любимого” ОАЦ.

same in Egypt, managed to let it work from my android using custom endpoint, but i don’t see any configuration about custom endpoint from Windows edition.
hope the devs add it soon

При тесте на белтелекоме Colocation center определился не MSQ, а LED (Saint Petersburg, Russia). Поэтому видимо там проблем нет.

@ZeroParty А откуда адрес Я гуглил, не нашел какого-то публичного списка адресов. Можно ли выбрать что-то другое, кроме Варшавы? - все подключаются к WAW, а в диапазоне - пробовал разные адреса, не подключает.

Все зависит от маршрутизации трафика к этим ip CloudFlare у конкретного интернет-оператора, бывало, что подключался и к Вильнюсу (VNO). Публично (в документации) никаких ip диапазонов и нет. Есть только dns - (, 2606:4700:d0::a29f:c001).
В таком случае фиксируем диапазон, как решение проблемы в Беларуси - Спасибо за дополнительные изыскания :wink:
Для проверки блокировки провайдером UDP к Cloudflare’s edge server в Linux, iMAC можно использовать команду: