Cloudflare App Not Working on Pi-Hole

          -Ug, New users can only put 4 links in a post. I'll replace some of the periods with _s.

Hi. I’m having some trouble with the Cloudflare app on the Pi-Hole I just put together. All of these steps worked fine on an older version of Raspbian.

OK, so here’s what’s going on with the latest install.
$ cloudflared -v
cloudflared version 2021.10.3 (built 2021-10-15-0915 UTC)

$ dig www_yahoo_com

; <<>> DiG 9.11.5-P4-5.1+deb10u5-Raspbian <<>> www_yahoo_com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12360
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;www_yahoo_com. IN A

;; ANSWER SECTION:
www_yahoo_com. 25 IN CNAME new-fp-shed.wg1.b.yahoo_com.
new-fp-shed.wg1.b.yahoo_com. 25 IN A 98.137.11_164
new-fp-shed.wg1.b.yahoo_com. 25 IN A 98.137.11_163

;; Query time: 21 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Thu Oct 21 05:51:30 BST 2021
;; MSG SIZE rcvd: 106

So it looks like my Pi-Hole is using 1.1.1.1, and getting a response on port 53. It is supposed to be using 127.0.0.1, port 5053. That’s where the couldflare app is supposed to be sending the info. Why would I think that? This is why:

$ sudo systemctl status cloudflared
● cloudflared.service - cloudflared DNS over HTTPS proxy
Loaded: loaded (/etc/systemd/system/cloudflared.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2021-10-20 06:32:13 BST; 20min ago
Main PID: 428 (cloudflared)
Tasks: 10 (limit: 2062)
CGroup: /system.slice/cloudflared.service
└─428 /usr/local/bin/cloudflared proxy-dns --port 5053 --upstream https://1.1.1_1/dns-query --upstream https://1.0.0_1/dns-query

Oct 20 06:32:13 raspberrypi systemd[1]: Started cloudflared DNS over HTTPS proxy.
Oct 20 06:32:15 raspberrypi cloudflared[428]: 2021-10-20T05:32:15Z INF Adding DNS upstream url=https://1.1.1_1/dns-query
Oct 20 06:32:15 raspberrypi cloudflared[428]: 2021-10-20T05:32:15Z INF Adding DNS upstream url=https://1.0.0_1/dns-query
Oct 20 06:32:15 raspberrypi cloudflared[428]: 2021-10-20T05:32:15Z INF Starting DNS over HTTPS proxy server address=dns://localhost:5053
Oct 20 06:32:15 raspberrypi cloudflared[428]: 2021-10-20T05:32:15Z INF Starting metrics server on 127.0.0.1:37283/metrics

The diagnotic page https://1.1.1_1/help shows that I’m not even connected to 1.1.1_1 for DNS. See here: https://1.1.1.1/help#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6IlllcyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjExMTEiOiJObyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjEwMDEiOiJObyIsImRhdGFjZW50ZXJMb2NhdGlvbiI6IllZQyIsImlzV2FycCI6Ik5vIiwiaXNwTmFtZSI6IkNsb3VkZmxhcmUiLCJpc3BBc24iOiIxMzMzNSJ9

I’m running Pi-Hole version 5.5, and Raspberry Pi OS Lite - Release date: May 7th 2021 - Kernel version: 5.10

What should I do to get DoH working? I suppose in the short term I can downgrade to an earlier version of Raspbian.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.