Cloudflare APO is blocking Google Mobile Friendly Test

I’ve been using Cloudflare APO for a few months. Today, Google Search Console inform me that there are a lot of my posts not mobile friendly!! I debugged what suddenly happened and found that Google Mobile bot can’t access to all website pages and posts.

I have cloned my website on a subdomain to investigate more and its clearly happening with APO. Below are things I done to investigate:

  1. Disabled all WordPress plugins.
  2. switching theme to default WordPress twenty twenty two.
  3. cleared the apo cache.
  4. testing with google, and same issue happened.

Example URL in question: https://nakib4tech.com/

The Issue is only fixed when I disable APO or use a page rule to bypass cache.

Please notice that I have disabled all the WAF via page rule and its not related to WAF.

Greetings,

I am sorry to hear you are experiencing an issue.

Furthermore, I have copy-paste source code and test it, it passed:

May I ask, have you tried to manually Purge the cache at Cloudflare dashboard?

Hi @fritex,

Thank you for your kind reply!

Yes of course, the issue is not with the HTML code. there are no errors in the code and even, no console errors.

You know, Google is accessing the website like any bot by inspecting the URLs, and that why its still showing +100 page not mobile friendly while they are fully responsible!

Yes Sir, I purged it manually at CF Dashboard and done a “purge everything”.

Just to confirm something. Its not only happening with the Google Mobile Friendly test, its also happening with Google Rich Results Test.

On the Rich Results Test if you choose “Googlebot for Desktop” it will pass! But if you choose Googlebot for mobile it will fail.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.