Cloudflare and Worldpay issue

Since enabling Cloudflare we are getting Worldpay Call Back failures.

Does anyone know how to resolve this please?

Error like this

Our systems have detected that your callback has failed.

This callback failure means we were unable to pass information
to your server about the following transaction:

Transaction ID: #########
Cart ID: wc_order_############################
Installation ID: #################

Error reported: Callback to: failed CAUSED BY Received fatal alert: handshake_failure
Server Reference: ukdc1-pz-pay07:callbackFailureEmail-9889:MerchReq-929-54

Many thanks

These requests most likey got blocked by Cloudflare. As a first try you can whitelist the IP address where the request comes from.

I am not seeing anything related to Worldpay blocked in the Cloudflare firewall event log which I thought I would if this was the case?

Many thanks

Thats a good point, the error message would actually rather hint at an SSL issue than an active block. Do all these requests fail or just some? What is your chosen TLS version in your Cloudflare control panel?

SSL is set to Full (Strict) Setting advised by hosting company
TLS Minimum is seto to TLS 1.0
TLS 1.3 Enabled

These settings generally sound all right. You could try to disable 1.3 altogether and check if that makes a difference, but in theory it shouldnt.

Again, how often do these handshake errors occur?

This is a related question with some workarounds.

Are you referring to these comments, Happy to try them, but the user on the thread has finished off saying their issue was still not resolved.

The solution does make sense providing the use still gets redirected back to the main site

I worked around the worldpay restriction with the following steps:

  1. Create new worldpay subdomain for the affected domain e.g.
  2. Secure with a free certificate from (it’s just a tick box during subdomain creation in Plesk 17)
  3. Move callback script for affected domain from its current location to the new worldpay subdomain. e.g. from to
  4. Create new worldpay CNAME entry in Cloudflare DNS page for the affected domain and turn the cloud off for the new CNAME
  5. Login to Worldpay admin interface and update the Payment Response URL for the affected installation to match the new URL you set up at step 3
  6. Test!

Now the worldpay system sends its callback POST to which Cloudflare sends directly to the server (rather than processing it with its SNI cert) and as long as the server has a valid cert installed from e.g. Let’s Encrypt, it works. No more handshake_failure messages

That was a different user, the OP appears to got it fixed that way.

My link points to post 15 which you rewrote here. Nice to hear you solved the issue.

Sorry I misinterpreted that. Looking to test the fix as soon as possible.

As were using a Worldpay plugin with Wordpress just doing some additional checks to ensure we can make this fix work.

Thanks for all the advice everyone will report back shortly.

1 Like

The fix suggested would not work with Cloudflare.

However the adding of a resultY.html file in the Worldpay file manager did fix the issues with Cloudflare and Worldpay not supporting SNI

Details here

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.