Cloudflare and WordFence Scan Issue

cdn
firewall
#1

Hello,

I am using WordFence as a security plugin in my main domain and in 2 subdomains from around 1 year without any issues.

However, after 1 February 2019, WordFence Security Scans aren’t happening in all of the websites that I mentioned earlier.

I go through all the troubleshooting method recommend by the plugin vendor, here —

However, I don’t know one thing, where I need you guys to help me. Is Cloudflare Blocking IP Address Range from “69.46.36.0 to 69.46.36.32” to make any outbound requests? This is the IP Address Range of WordFence Server.

I already checked my cPanel and all of my website’s to see if I am blocking those IP Address range or not. I am not blocking those IP Address range from my side.

And also I contacted my Hosting provider, to know if they are blocking those IP Address
range or not. They are not blocking this IP Range and they are saying Cloudflare might block those IP Address as an attack.

Is Cloudflare Blocking IP Address Range from “69.46.36.0 to 69.46.36.32” by any chance or anyone having the same kind of issue?

Thanks…

0 Likes

#2

You can try creating a Firewall Rule for this IP range with action “Allow”, which will make Cloudflare bypass its own security measures for the IPs.

https://developers.cloudflare.com/firewall/known-issues-and-faq/#how-does-firewall-rules-handle-traffic-from-known-bots

If the issue persists, you will be able to verify on the Firewall Events log that the IPs are being allowed, and concentrate your search for a solution elsewhere (another WP plugin perhaps)

1 Like

#3

My Wordfence scans are still working. Now I have to dig through old memories of a time when my scans were failing. You could use Wordfence Tools and go to Diagnostics to turn on debugging.

I’m still trying to remember what caused my scans to fail, but I believe it was server-related. Ran out of memory…a file was too big to scan…something. But the scans were starting.

Now another memory is surfacing of scans not even kicking off. Have you whitelisted your server’s IP address in the Cloudflare Firewall?

I know Åsa from Wordfence helped me with these issues, but I think the tickets rolled off their system. I believe I was using a now-defunct email address back then.

2 Likes

#4

Thanks for the reply.

Actually, I implemented a Firewall Rule for this IP range with action “Allow” and tried to scan. However, no luck.

Yes, I looked into the Firewall events log and those IPs are successfully allowed.

So, WordFence Plugin seems to be the problem.

Anyway, thanks for the inputs.

1 Like

#5

Thanks for the reply.

Now, Its seems to be Plugin Issue.

I think now is the good time to contact Plugin Support.

0 Likes

#6

I am having same issue!

0 Likes

#7

I’m pretty sure that enabling Debugging, as I suggested above, was the key to getting this working again.

Have you tried that?

0 Likes

closed #8

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes