Cloudflare and Freekassa

Error:

HTTP/1.1 301 Moved Permanently
Date: Sun, 25 Jul 2021 10:26:02 GMT
Transfer-Encoding: chunked
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Sun, 25 Jul 2021 11:26:02 GMT
Location: https://tollwin.ru/inc/fkassa.php
cf-request-id: 0b7ecc5c3f00004e98de18d000000001
Report-To: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v3?s=yLG9H5jAAsmwVa7FNAdTuENejdBj3MA76jSsMnp9OZUyVn7DzKFjAjZy%2FeAKzvimUQexxvPWgFB0gpR3sPTFPg0JzfeOt2HsgdHJXWpLvK8Mjx0WQs4uuGtt06mG"}],“group”:“cf-nel”,"max_age”:604800}
NEL: {“report_to”:“cf-nel”,“max_age”:604800}
Server: cloudflare
CF-RAY: 6744b00d3c394e98-FRA
The addresses are written in a white sheet, but everything exactly outputs an error, help me please

May I ask what is the issue here?

I see this wehn I open fkassa.php.

The Cloudflare IP address is being blocked by the hosting provider or by your host?

May I ask have you allowed Cloudflare to connect to your host origin/server following the instructons from the below article?:

Cloudflare IP address list can be found here:

Or, you may also need the real IP address of a visitor?:

in .htaccess added

deny from 103.21.244.0/22
deny from 103.22.200.0/22
deny from 103.31.4.0/22
deny from 104.16.0.0/13
deny from 104.24.0.0/14
deny from 108.162.192.0/18
deny from 131.0.72.0/22
deny from 141.101.64.0/18
deny from 162.158.0.0/15
deny from 172.64.0.0/13
deny from 173.245.48.0/20
deny from 188.114.96.0/20
deny from 190.93.240.0/20
deny from 197.234.240.0/22
deny from 198.41.128.0/17

I made a mistake, allow

1 Like

and

iptables -I INPUT -p tcp -m multiport --dports http,https -s 103.21.244.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 103.22.200.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 103.31.4.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 104.16.0.0/13 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 104.24.0.0/14 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 108.162.192.0/18 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 131.0.72.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 141.101.64.0/18 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 162.158.0.0/15 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 172.64.0.0/13 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 173.245.48.0/20 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 188.114.96.0/20 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 190.93.240.0/20 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 197.234.240.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 198.41.128.0/17 -j ACCEPT

1 Like

You might say allow, but that server is clearly blocking Cloudflare IP addresses.

Your original post says there’s an error, but a 301 isn’t an error. It’s a redirect.

1 Like

And do not forget to run iptables-save to apply and save that changes :wink:

The link is only available to CloudFlare and FreeKassa

Thank you)

1 Like

Now I got response of my IP shown:
Address my.ip.address.here is block!

this good

Okay, not my IP. Wrongly saw.
I got Cloudflare host IP again.

Still blocking Cloudflare for me.

1 Like

i have virtual hosting, they say that you can’t configure it

Can’t configure what? Hosting should start by allowing everything, then block as needed.

I turned to the assistants, asked to use commands in ssh

iptables -I INPUT -p tcp -m multiport --dports http,https -s 103.21.244.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 103.22.200.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 103.31.4.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 104.16.0.0/13 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 104.24.0.0/14 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 108.162.192.0/18 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 131.0.72.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 141.101.64.0/18 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 162.158.0.0/15 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 172.64.0.0/13 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 173.245.48.0/20 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 188.114.96.0/20 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 190.93.240.0/20 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 197.234.240.0/22 -j ACCEPT
iptables -I INPUT -p tcp -m multiport --dports http,https -s 198.41.128.0/17 -j ACCEPT

Sorry, but we can’t help you due to your server settings. Please turn off all firewall settings at your host, including .htaccess

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.